Project

General

Profile

Bug #62084

task/test_nfs: AttributeError: 'TestNFS' object has no attribute 'run_ceph_cmd'

Added by Adam King 7 months ago. Updated 23 days ago.

Status:
Pending Backport
Priority:
Normal
Assignee:
Category:
Testing
Target version:
% Done:

0%

Source:
Tags:
backport_processed
Backport:
reef,quincy
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
Labels (FS):
qa, qa-failure
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

2023-07-19T14:05:01.460 INFO:tasks.cephfs_test_runner:test_cluster_info (tasks.cephfs.test_nfs.TestNFS) ... ERROR
2023-07-19T14:05:01.461 INFO:tasks.cephfs_test_runner:
2023-07-19T14:05:01.461 INFO:tasks.cephfs_test_runner:======================================================================
2023-07-19T14:05:01.461 INFO:tasks.cephfs_test_runner:ERROR: test_cluster_info (tasks.cephfs.test_nfs.TestNFS)
2023-07-19T14:05:01.461 INFO:tasks.cephfs_test_runner:----------------------------------------------------------------------
2023-07-19T14:05:01.462 INFO:tasks.cephfs_test_runner:Traceback (most recent call last):
2023-07-19T14:05:01.462 INFO:tasks.cephfs_test_runner:  File "/home/teuthworker/src/git.ceph.com_ceph-c_4ae2a76aad461f2c9f6a1456c25df23ec97a5b2f/qa/tasks/cephfs/test_nfs.py", line 578, in test_cluster_info
2023-07-19T14:05:01.462 INFO:tasks.cephfs_test_runner:    self._test_create_cluster()
2023-07-19T14:05:01.462 INFO:tasks.cephfs_test_runner:  File "/home/teuthworker/src/git.ceph.com_ceph-c_4ae2a76aad461f2c9f6a1456c25df23ec97a5b2f/qa/tasks/cephfs/test_nfs.py", line 156, in _test_create_cluster
2023-07-19T14:05:01.462 INFO:tasks.cephfs_test_runner:    cluster_create = self._nfs_complete_cmd(
2023-07-19T14:05:01.463 INFO:tasks.cephfs_test_runner:  File "/home/teuthworker/src/git.ceph.com_ceph-c_4ae2a76aad461f2c9f6a1456c25df23ec97a5b2f/qa/tasks/cephfs/test_nfs.py", line 25, in _nfs_complete_cmd
2023-07-19T14:05:01.463 INFO:tasks.cephfs_test_runner:    return self.run_ceph_cmd(args=f"nfs {cmd}", stdout=StringIO(),
2023-07-19T14:05:01.463 INFO:tasks.cephfs_test_runner:AttributeError: 'TestNFS' object has no attribute 'run_ceph_cmd'
2023-07-19T14:05:01.463 INFO:tasks.cephfs_test_runner:
2023-07-19T14:05:01.463 INFO:tasks.cephfs_test_runner:----------------------------------------------------------------------
2023-07-19T14:05:01.464 INFO:tasks.cephfs_test_runner:Ran 1 test in 41.215s
2023-07-19T14:05:01.464 INFO:tasks.cephfs_test_runner:
2023-07-19T14:05:01.464 INFO:tasks.cephfs_test_runner:FAILED (errors=1)
2023-07-19T14:05:01.464 INFO:tasks.cephfs_test_runner:
2023-07-19T14:05:01.464 INFO:tasks.cephfs_test_runner:======================================================================
2023-07-19T14:05:01.465 INFO:tasks.cephfs_test_runner:ERROR: test_cluster_info (tasks.cephfs.test_nfs.TestNFS)
2023-07-19T14:05:01.465 INFO:tasks.cephfs_test_runner:----------------------------------------------------------------------
2023-07-19T14:05:01.465 INFO:tasks.cephfs_test_runner:Traceback (most recent call last):
2023-07-19T14:05:01.465 INFO:tasks.cephfs_test_runner:  File "/home/teuthworker/src/git.ceph.com_ceph-c_4ae2a76aad461f2c9f6a1456c25df23ec97a5b2f/qa/tasks/cephfs/test_nfs.py", line 578, in test_cluster_info
2023-07-19T14:05:01.465 INFO:tasks.cephfs_test_runner:    self._test_create_cluster()
2023-07-19T14:05:01.465 INFO:tasks.cephfs_test_runner:  File "/home/teuthworker/src/git.ceph.com_ceph-c_4ae2a76aad461f2c9f6a1456c25df23ec97a5b2f/qa/tasks/cephfs/test_nfs.py", line 156, in _test_create_cluster
2023-07-19T14:05:01.466 INFO:tasks.cephfs_test_runner:    cluster_create = self._nfs_complete_cmd(
2023-07-19T14:05:01.466 INFO:tasks.cephfs_test_runner:  File "/home/teuthworker/src/git.ceph.com_ceph-c_4ae2a76aad461f2c9f6a1456c25df23ec97a5b2f/qa/tasks/cephfs/test_nfs.py", line 25, in _nfs_complete_cmd
2023-07-19T14:05:01.466 INFO:tasks.cephfs_test_runner:    return self.run_ceph_cmd(args=f"nfs {cmd}", stdout=StringIO(),
2023-07-19T14:05:01.466 INFO:tasks.cephfs_test_runner:AttributeError: 'TestNFS' object has no attribute 'run_ceph_cmd'

https://pulpito.ceph.com/adking-2023-07-19_13:28:53-orch:cephadm-wip-adk4-testing-2023-07-18-1038-distro-default-smithi/7343320/

looks related to this recent change https://github.com/ceph/ceph/pull/50569


Related issues

Related to CephFS - Bug #62073: AttributeError: 'TestNFS' object has no attribute 'run_ceph_cmd' Duplicate
Copied to CephFS - Backport #64204: quincy: task/test_nfs: AttributeError: 'TestNFS' object has no attribute 'run_ceph_cmd' New
Copied to CephFS - Backport #64205: reef: task/test_nfs: AttributeError: 'TestNFS' object has no attribute 'run_ceph_cmd' New

History

#1 Updated by Venky Shankar 7 months ago

  • Related to Bug #62073: AttributeError: 'TestNFS' object has no attribute 'run_ceph_cmd' added

#2 Updated by Venky Shankar 7 months ago

  • Project changed from Orchestrator to CephFS
  • Category set to Testing
  • Status changed from New to Fix Under Review
  • Assignee set to Adam King
  • Target version set to v19.0.0
  • Pull request ID set to 52556
  • Labels (FS) qa, qa-failure added

#3 Updated by Laura Flores 7 months ago

/a/yuriw-2023-07-21_02:03:58-rados-wip-yuri7-testing-2023-07-20-0727-distro-default-smithi/7346244

#4 Updated by Venky Shankar 7 months ago

/a/vshankar-2023-07-26_04:54:56-fs-wip-vshankar-testing-20230725.053049-testing-default-smithi/7352573

2023-07-26T08:07:59.154 INFO:tasks.cephfs_test_runner:======================================================================
2023-07-26T08:07:59.154 INFO:tasks.cephfs_test_runner:ERROR: test_disallow_monitor_managed_snaps_for_fs_pools (tasks.cephfs.test_snapshots.TestMonSnapsAndFsPools)
2023-07-26T08:07:59.155 INFO:tasks.cephfs_test_runner:----------------------------------------------------------------------
2023-07-26T08:07:59.155 INFO:tasks.cephfs_test_runner:Traceback (most recent call last):
2023-07-26T08:07:59.155 INFO:tasks.cephfs_test_runner:  File "/home/teuthworker/src/git.ceph.com_ceph-c_dac78ca1620f95e090b780a3d659e716e6db4ce8/qa/tasks/cephfs/test_snapshots.py", line 556, in test_disallow_monitor_managed_snaps_for_fs_pools
2023-07-26T08:07:59.155 INFO:tasks.cephfs_test_runner:    self.run_cluster_cmd(base_cmd)
2023-07-26T08:07:59.155 INFO:tasks.cephfs_test_runner:AttributeError: 'TestMonSnapsAndFsPools' object has no attribute 'run_cluster_cmd'
2023-07-26T08:07:59.156 INFO:tasks.cephfs_test_runner:
2023-07-26T08:07:59.156 INFO:tasks.cephfs_test_runner:----------------------------------------------------------------------

This instance has `run_cluster_cmd` (instead of `run_ceph_cmd`). Guessing this is a fallout of the same commit (or one of the related commits).

#5 Updated by Rishabh Dave 7 months ago

Venky Shankar wrote:

/a/vshankar-2023-07-26_04:54:56-fs-wip-vshankar-testing-20230725.053049-testing-default-smithi/7352573

[...]

This instance has `run_cluster_cmd` (instead of `run_ceph_cmd`). Guessing this is a fallout of the same commit (or one of the related commits).

Yes, this failure too seems to be related to https://github.com/ceph/ceph/pull/50569.
The call which is failing in traceback was added here - https://github.com/ceph/ceph/pull/51275/files#diff-2417647710527fa3628daa0e2b0ed2bbfe8cb68a224a086f7593cd8ec1a0aa3cR556. test_snapshots.py is found only in one location in qa/suites/fs -

$ grep -rnI test_snapshots qa/suites/fs/
qa/suites/fs/functional/tasks/snapshots.yaml:16:      - tasks.cephfs.test_snapshots

I checked the results of teuthology test run and this test_snapshot.py was run but the failure did not occur. This is so because this change was not present on the testing branch on CephFSTestCase PR. I'll create a new tracker for this issue.

#6 Updated by Rishabh Dave 7 months ago

Rishabh Dave wrote:

Venky Shankar wrote:

/a/vshankar-2023-07-26_04:54:56-fs-wip-vshankar-testing-20230725.053049-testing-default-smithi/7352573

[...]

This instance has `run_cluster_cmd` (instead of `run_ceph_cmd`). Guessing this is a fallout of the same commit (or one of the related commits).

Yes, this failure too seems to be related to https://github.com/ceph/ceph/pull/50569.
The call which is failing in traceback was added here - https://github.com/ceph/ceph/pull/51275/files#diff-2417647710527fa3628daa0e2b0ed2bbfe8cb68a224a086f7593cd8ec1a0aa3cR556. test_snapshots.py is found only in one location in qa/suites/fs -

[...]

I checked the results of teuthology test run and this test_snapshot.py was run but the failure did not occur. This is so because this change was not present on the testing branch on CephFSTestCase PR. I'll create a new tracker for this issue.

Here's the new ticket I've created for this issue - https://tracker.ceph.com/issues/62243

#7 Updated by Laura Flores 6 months ago

/a/yuriw-2023-08-11_02:49:40-rados-wip-yuri4-testing-2023-08-10-1739-distro-default-smithi/7367034

#8 Updated by Laura Flores 6 months ago

/a/yuriw-2023-08-17_21:18:20-rados-wip-yuri11-testing-2023-08-17-0823-distro-default-smithi/7372041

#9 Updated by Matan Breizman 6 months ago

/a/yuriw-2023-08-22_18:16:03-rados-wip-yuri10-testing-2023-08-17-1444-distro-default-smithi/7376742

#10 Updated by Rishabh Dave 6 months ago

  • Status changed from Fix Under Review to Resolved

#11 Updated by Rishabh Dave 6 months ago

  • Pull request ID changed from 52556 to 52924

PR https://github.com/ceph/ceph/pull/52924 has been merged for fixing this issue. Original PR https://github.com/ceph/ceph/pull/52556 was supposed to do it.

#12 Updated by Milind Changire 23 days ago

  • Backport set to reef,quincy

#13 Updated by Venky Shankar 23 days ago

  • Status changed from Resolved to Pending Backport

Milind is seeing this error in a reef run - this needs backporting to quincy and reef, yes?

#14 Updated by Backport Bot 23 days ago

  • Copied to Backport #64204: quincy: task/test_nfs: AttributeError: 'TestNFS' object has no attribute 'run_ceph_cmd' added

#15 Updated by Backport Bot 23 days ago

  • Copied to Backport #64205: reef: task/test_nfs: AttributeError: 'TestNFS' object has no attribute 'run_ceph_cmd' added

#16 Updated by Backport Bot 23 days ago

  • Tags set to backport_processed

#17 Updated by Rishabh Dave 23 days ago

Milind is seeing this error in a reef run - this needs backporting to quincy and reef, yes?

Backport PRs were created some time ago.

Here's the backport commit for quincy - https://github.com/ceph/ceph/pull/54946/commits/04541ca2baa491b4634ce5f1f7ea32c8c14f5d63 and here's the backport commit for reef - https://github.com/ceph/ceph/pull/54945/commits/2a8a36de0f14684a99a9507da8ad8cbba32e3dc2.

Also available in: Atom PDF