Project

General

Profile

Bug #62243

qa/cephfs: test_snapshots.py fails because of a missing method

Added by Rishabh Dave 7 months ago. Updated 7 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
Labels (FS):
qa, qa-failure
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

test_disallow_monitor_managed_snaps_for_fs_pools (in test_snapshot.TestMonSnapsAndFsPools) fails because method "run_cluster_cmd" doesn't exist in TestMonSnapsAndFsPools.

2023-07-26T08:07:59.154 INFO:tasks.cephfs_test_runner:======================================================================
2023-07-26T08:07:59.154 INFO:tasks.cephfs_test_runner:ERROR: test_disallow_monitor_managed_snaps_for_fs_pools (tasks.cephfs.test_snapshots.TestMonSnapsAndFsPools)
2023-07-26T08:07:59.155 INFO:tasks.cephfs_test_runner:----------------------------------------------------------------------
2023-07-26T08:07:59.155 INFO:tasks.cephfs_test_runner:Traceback (most recent call last):
2023-07-26T08:07:59.155 INFO:tasks.cephfs_test_runner:  File "/home/teuthworker/src/git.ceph.com_ceph-c_dac78ca1620f95e090b780a3d659e716e6db4ce8/qa/tasks/cephfs/test_snapshots.py", line 556, in test_disallow_monitor_managed_snaps_for_fs_pools
2023-07-26T08:07:59.155 INFO:tasks.cephfs_test_runner:    self.run_cluster_cmd(base_cmd)
2023-07-26T08:07:59.155 INFO:tasks.cephfs_test_runner:AttributeError: 'TestMonSnapsAndFsPools' object has no attribute 'run_cluster_cmd'
2023-07-26T08:07:59.156 INFO:tasks.cephfs_test_runner:
2023-07-26T08:07:59.156 INFO:tasks.cephfs_test_runner:----------------------------------------------------------------------

This failure occurred here - /a/vshankar-2023-07-26_04:54:56-fs-wip-vshankar-testing-20230725.053049-testing-default-smithi/7352573. It was discovered by Venky and originally report here - https://tracker.ceph.com/issues/62084#note-4.

This call was added here - https://github.com/ceph/ceph/pull/51275/files#diff-2417647710527fa3628daa0e2b0ed2bbfe8cb68a224a086f7593cd8ec1a0aa3cR556. The root cause of this failure is that PR 51275 and PR 50569 were merged too close to each other. So this change was absent on the testing branch of PR #50569 and, therefore, test_snapshot.py never failed in integration test runs. However, since both the PRs were merged, we see this failure now in recent integration test runs.

History

#1 Updated by Rishabh Dave 7 months ago

  • Subject changed from qa/cephfs: to qa/cephfs: test_snapshots.py fails because of a missing method

#2 Updated by Rishabh Dave 7 months ago

  • Status changed from New to In Progress

#3 Updated by Rishabh Dave 7 months ago

  • Description updated (diff)

#4 Updated by Rishabh Dave 7 months ago

  • Description updated (diff)

#5 Updated by Venky Shankar 7 months ago

  • Status changed from In Progress to Fix Under Review
  • Pull request ID set to 52709

I think this doesn't need backport, Rishabh?

#6 Updated by Rishabh Dave 7 months ago

Venky Shankar wrote:

I think this doesn't need backport, Rishabh?

No need because the PR that introduced this bug (https://github.com/ceph/ceph/pull/50569) isn't backported.

#7 Updated by Rishabh Dave 7 months ago

  • Status changed from Fix Under Review to Resolved

Also available in: Atom PDF