Project

General

Profile

Actions

Bug #49348

closed

cephadm: giving nonexistent service for service action command should return error

Added by Adam King over 3 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Low
Assignee:
Category:
cephadm
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
pacific
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

Right now, if a user runs a command like "ceph orch redeploy . . ." and gives an incorrect service name no output is provided. This can be confusing for users, especially in cases where the service name is wrong because the service id was not included (e.g. "ceph orch redeploy iscsi"). Instead the user should be informed that the service they provided was incorrect.


Related issues 1 (0 open1 closed)

Is duplicate of Orchestrator - Feature #49246: cephadm: Display error message when given service name is wrongDuplicate

Actions
Actions #1

Updated by Adam King over 3 years ago

  • Status changed from New to Fix Under Review
  • Pull request ID set to 39537
Actions #2

Updated by Gunther Heinrich over 3 years ago

Thanks a lot for working on this. Is this linked to the feature request / bug #49246 I issued some days ago? In that case an admin could mark my ticket as a duplicate.

Actions #3

Updated by Ken Dreyer about 3 years ago

  • Status changed from Fix Under Review to Pending Backport
  • Backport set to pacific
Actions #4

Updated by Adam King about 3 years ago

  • Is duplicate of Feature #49246: cephadm: Display error message when given service name is wrong added
Actions #5

Updated by Adam King about 3 years ago

  • Status changed from Pending Backport to Duplicate
Actions #6

Updated by Adam King about 3 years ago

  • Status changed from Duplicate to Pending Backport
Actions #7

Updated by Sage Weil about 3 years ago

  • Status changed from Pending Backport to Resolved
Actions

Also available in: Atom PDF