Project

General

Profile

Bug #46566

octopus: mgr/dashboard: fix rbdmirroring dropdown menu

Added by Avan Thakkar 2 months ago. Updated about 1 month ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
dashboard/usability
Target version:
% Done:

0%

Source:
Tags:
Backport:
Regression:
Yes
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

Block -> RBD mirroring: "Edit site name" (top-rightmost button), when clicked, opens a drop-down menu with spans out of the visible screen (it's not cropped, but requires the user to manually scroll the screen to the right).

Screenshot from 2020-07-16 16-17-22.png View (8.01 KB) Avan Thakkar, 07/16/2020 10:47 AM

History

#1 Updated by Avan Thakkar 2 months ago

  • File deleted (rbd_mirroring_menu_too_right.png)

#2 Updated by Avan Thakkar 2 months ago

  • Subject changed from mgr/dashboard: fix rbdmirroring dropdown menu to mgr/dashboard: octopus: fix rbdmirroring dropdown menu

#3 Updated by Avan Thakkar 2 months ago

  • Backport deleted (octopus)

#4 Updated by Avan Thakkar 2 months ago

Avan Thakkar wrote:

Block -> RBD mirroring: "Edit site name" (top-rightmost button), when clicked, opens a drop-down menu with spans out of the visible screen (it's not cropped, but requires the user to manually scroll the screen to the right).

#5 Updated by Nathan Cutler 2 months ago

@Avan, I noticed you removed the octopus backport, but added "octopus:" to the subject line. That would seem to indicate that the bug exists only in octopus, and not in master. Is that the case? Can you elaborate a bit? (Normally we would try to find which commit(s) fixed the bug in master, and then backport those to octopus....)

#6 Updated by Avan Thakkar about 2 months ago

Nathan Cutler wrote:

@Avan, I noticed you removed the octopus backport, but added "octopus:" to the subject line. That would seem to indicate that the bug exists only in octopus, and not in master. Is that the case? Can you elaborate a bit? (Normally we would try to find which commit(s) fixed the bug in master, and then backport those to octopus....)

Yes, the issue is reproducible only in octopus and not in master. As the master branch already has dropdown right aligned, so there the issue doesn't happen

#7 Updated by Nathan Cutler about 2 months ago

Yes, the issue is reproducible only in octopus and not in master. As the master branch already has dropdown right aligned, so there the issue doesn't happen

So would it make sense to:

1. determine which commit/PR (commits/PRs) fixed the issue in master
2. backport those to octopus?

#8 Updated by Nathan Cutler about 2 months ago

  • Subject changed from mgr/dashboard: octopus: fix rbdmirroring dropdown menu to octopus: mgr/dashboard: fix rbdmirroring dropdown menu
  • Category set to dashboard/usability

#9 Updated by Avan Thakkar about 2 months ago

Nathan Cutler wrote:

Yes, the issue is reproducible only in octopus and not in master. As the master branch already has dropdown right aligned, so there the issue doesn't happen

So would it make sense to:

1. determine which commit/PR (commits/PRs) fixed the issue in master
2. backport those to octopus?

I think the changes in master are due to replacement of ng-bootstrap to ngx- and they haven't been backported yet in octopus. So maybe for now should I just create PR to fix the issue for octopus only?

#10 Updated by Tiago Melo about 2 months ago

This seems to be the same situations as https://tracker.ceph.com/issues/44458, but in a different part of the frontend.
Since we are not backporting ngx-bootstrap to octopus, this has to be manually fixed in octopus.

#11 Updated by Avan Thakkar about 2 months ago

  • Pull request ID set to 36382

#12 Updated by Avan Thakkar about 2 months ago

  • Status changed from New to Fix Under Review

#13 Updated by Lenz Grimmer about 1 month ago

  • Status changed from Fix Under Review to Resolved
  • Target version set to v15.2.5

#14 Updated by Lenz Grimmer about 1 month ago

  • Regression changed from No to Yes

Also available in: Atom PDF