Project

General

Profile

Bug #44458

octopus: mgr/dashboard: dropmenu item of column filters might exceed the viewport boundary

Added by Kiefer Chang 9 months ago. Updated 4 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
dashboard/UI
Target version:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

If the item's length is too long, then it might exceed the viewport.

The item is only visible when user scroll right:

We should make it visible inside the viewport to avoid scrolling.

Screenshot_20200306_110308.png View (71 KB) Kiefer Chang, 03/06/2020 03:08 AM

Screenshot_20200306_110316.png View (61.7 KB) Kiefer Chang, 03/06/2020 03:08 AM

History

#1 Updated by Kiefer Chang 4 months ago

I don't see this in the master code (v16) because every dropdown menu is right-aligned.

#2 Updated by Kiefer Chang 4 months ago

  • Status changed from New to In Progress
  • Assignee set to Kiefer Chang
  • Affected Versions v15.2.5 added

#3 Updated by Kiefer Chang 4 months ago

  • Status changed from In Progress to Fix Under Review
  • Pull request ID set to 36369

#4 Updated by Tiago Melo 4 months ago

  • Subject changed from mgr/dashboard: dropmenu item of column filters might exceed the viewport boundary to octopus: mgr/dashboard: dropmenu item of column filters might exceed the viewport boundary

#5 Updated by Lenz Grimmer 4 months ago

  • Tags set to usability
  • Target version set to v15.2.5

#6 Updated by Lenz Grimmer 4 months ago

  • Status changed from Fix Under Review to Resolved

Also available in: Atom PDF