Project

General

Profile

Bug #42608

mgr/dashboard: dashboard e2e Jenkins job failures when editing placement groups

Added by Laura Paduano 5 months ago. Updated 5 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
dashboard/qa
Target version:
-
% Done:

0%

Source:
Development
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

  Pools page

    breadcrumb and tab tests
      ✓ should open and show breadcrumb (0.071 sec)
      ✓ should show two tabs (0.027 sec)
      ✓ should show pools list tab at first (0.05 sec)
      ✓ should show overall performance as a second tab (0.049 sec)

    ✓ should create a pool (7 secs)
    ✗ should edit a pools placement group (25 secs)
      - Failed: Timed out waiting for placement group to be updated
      Wait timed out after 20009ms
      Wait timed out after 20009ms
          at /ceph/src/pybind/mgr/dashboard/frontend/node_modules/selenium-webdriver/lib/promise.js:2201:17
          at process._tickCallback (internal/process/next_tick.js:68:7)
      From asynchronous test:
      Error:
          at Suite.<anonymous> (/ceph/src/pybind/mgr/dashboard/frontend/e2e/pools/pools.e2e-spec.ts:42:3)
          at apply (/ceph/src/pybind/mgr/dashboard/frontend/node_modules/lodash/lodash.js:476:27)
          at Env.wrapper [as describe] (/ceph/src/pybind/mgr/dashboard/frontend/node_modules/lodash/lodash.js:5317:16)
          at Object.<anonymous> (/ceph/src/pybind/mgr/dashboard/frontend/e2e/pools/pools.e2e-spec.ts:3:1)
          at Module._compile (internal/modules/cjs/loader.js:776:30)

Seems to be related to

  progress:
    PG autoscaler decreasing pool 11 PGs from 20 to 4 (00h 01m 00s)
      [============................] (time remaining: 00h 01m 20s)

Related issues

Related to RADOS - Feature #42638: Allow specifying pg_autoscale_mode when creating a new pool Resolved
Related to mgr - Fix #43102: mgr/dashboard: remove E2E test workaround for autoscaler Resolved

History

#2 Updated by Sebastian Wagner 5 months ago

  • Status changed from New to 12

#3 Updated by Kiefer Chang 5 months ago

  • Related to Feature #42638: Allow specifying pg_autoscale_mode when creating a new pool added

#4 Updated by Kiefer Chang 5 months ago

  • Status changed from 12 to Fix Under Review
  • Pull request ID set to 31396

#5 Updated by Laura Paduano 5 months ago

  • Status changed from Fix Under Review to Resolved

#6 Updated by Laura Paduano 5 months ago

  • Assignee set to Kiefer Chang

#7 Updated by Patrick Seidensal 4 months ago

  • Related to Fix #43102: mgr/dashboard: remove E2E test workaround for autoscaler added

Also available in: Atom PDF