Project

General

Profile

Bug #42480

mgr/dashboard: searching table with data in Object types make Dashboard unresponsive

Added by Kiefer Chang about 1 year ago. Updated 8 months ago.

Status:
Resolved
Priority:
Normal
Category:
dashboard/general
Target version:
% Done:

0%

Source:
Tags:
Backport:
nautilus
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

For the table component, if the column data are Objects, searching table breaks the UI.
This issue is spotted when investigating #36354.

To reproduce this issue:
  1. Create a pool with RBD application
  2. Create a image on that pool
  3. Snapshot the image and protect the snapshot
  4. Clone the snapshot to a new image
  5. On image list table, search anything in the search box. A exception is displayed in the console and the GUI is unresponsive unless refreshing the whole app.

A preliminary investigation to the cause of the issue is the parent column of second RBD image is a Object, and the code falls through to the last statement in this snippet:
https://github.com/ceph/ceph/blob/4ea43f734254871c575761f0be4d859fd7f2a172/src/pybind/mgr/dashboard/frontend/src/app/shared/datatable/table/table.component.ts#L529-L544

search_exception.png View (111 KB) Kiefer Chang, 10/25/2019 02:19 AM


Related issues

Related to mgr - Bug #36354: mgr/dashboard/rbd: throws 500s with format 1 RBD images Resolved
Copied to mgr - Backport #42673: nautilus: mgr/dashboard: searching table with data in Object types make Dashboard unresponsive Resolved

History

#1 Updated by Kiefer Chang about 1 year ago

  • Related to Bug #36354: mgr/dashboard/rbd: throws 500s with format 1 RBD images added

#2 Updated by Lenz Grimmer about 1 year ago

  • Assignee set to Stephan Müller

@Stephan can you please take a look?

#3 Updated by Stephan Müller about 1 year ago

  • Status changed from New to In Progress

#4 Updated by Stephan Müller about 1 year ago

  • Status changed from In Progress to Fix Under Review
  • Pull request ID set to 31199

#5 Updated by Lenz Grimmer about 1 year ago

  • Status changed from Fix Under Review to Pending Backport

#6 Updated by Nathan Cutler about 1 year ago

  • Copied to Backport #42673: nautilus: mgr/dashboard: searching table with data in Object types make Dashboard unresponsive added

#7 Updated by Nathan Cutler 8 months ago

  • Status changed from Pending Backport to Resolved

While running with --resolve-parent, the script "backport-create-issue" noticed that all backports of this issue are in status "Resolved" or "Rejected".

Also available in: Atom PDF