Project

General

Profile

Bug #17105

multimds: allow_multimds not required when max_mds is set in ceph.conf at startup

Added by Patrick Donnelly 9 months ago. Updated 8 months ago.

Status:
Resolved
Priority:
Normal
Category:
multi-MDS
Target version:
-
Start date:
08/23/2016
Due date:
% Done:

0%

Source:
Development
Tags:
Backport:
jewel
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Release:
jewel
Component(FS):
MDSMonitor
Needs Doc:

Description

Problem:

$ vstart.sh -d -l --short -n -o 'max_mds = 3'
[...]
$ ceph status
    cluster 24600546-44d2-41ad-85ba-996b7af1fd73
     health HEALTH_OK
     monmap e1: 3 mons at {a=127.0.0.1:6789/0,b=127.0.0.1:6790/0,c=127.0.0.1:6791/0}
            election epoch 6, quorum 0,1,2 a,b,c
      fsmap e7: 3/3/3 up {0=a=up:active,1=c=up:creating,2=b=up:active}
     osdmap e10: 3 osds: 3 up, 3 in
            flags sortbitwise,require_jewel_osds,require_kraken_osds
      pgmap v13: 24 pgs, 3 pools, 0 bytes data, 0 objects
            550 GB used, 114 GB / 664 GB avail
                  24 active+clean
$ ceph mds set_max_mds 4
Error EINVAL: multi-MDS clusters are not enabled; set 'allow_multimds' to enable

The last command is not the problem. It's just showing what we currently do when trying to set max_mds when the flag is unset. The "issue" is that setting max_mds in the ceph.conf enables multimds but the CEPH_MDSMAP_ALLOW_MULTIMDS is not also set.

Either we should:

  1. Enable allow_multimds by setting the CEPH_MDSMAP_ALLOW_MULTIMDS flag so the administrator can modify max_mds without redundantly setting the flag (because multimds is already enabled even though the flag is unset).
  2. Require a new config option setting allow_multimds in addition to max_mds and reject max_mds otherwise (silently?).

Related issues

Copied to Backport #17264: jewel: multimds: allow_multimds not required when max_mds is set in ceph.conf at startup Resolved

History

#1 Updated by Greg Farnum 9 months ago

I think we want to force users to set multi-mds flags explicitly, not implicitly via the initial config. I'm fine with it being silent if being loud is inconvenient.

#2 Updated by Patrick Donnelly 9 months ago

  • Status changed from New to Need Review

#4 Updated by John Spray 9 months ago

  • Status changed from Need Review to Pending Backport

#5 Updated by Patrick Donnelly 9 months ago

  • Release jewel added

#6 Updated by Loic Dachary 9 months ago

  • Backport set to jewel

#7 Updated by Loic Dachary 9 months ago

  • Copied to Backport #17264: jewel: multimds: allow_multimds not required when max_mds is set in ceph.conf at startup added

#8 Updated by Loic Dachary 8 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF