Project

General

Profile

Bug #911

Multi-MDS Ceph does not pass fsstress

Added by Greg Farnum over 8 years ago. Updated over 8 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
Category:
-
Target version:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

Following on from #859, which handled the single-MDS bugs.

Hopefully we'll just have the one new bug, otherwise this bug will serve as an umbrella for the new ones we pick up on.

mds/Server.cc: In function 'void Server::handle_slave_rename_prep(MDRequest*)', in thread '0x7f07bbe41710'
mds/Server.cc: 5187: FAILED assert(r == 0)
 ceph version 0.25-298-g157e6bd (commit:157e6bdc52aac6aa00a84edbd596ff49fe60e086)
 1: (Server::handle_slave_rename_prep(MDRequest*)+0x1b9c) [0x51fe2c]
 2: (Server::dispatch_slave_request(MDRequest*)+0x32b) [0x5252eb]
 3: (Server::handle_slave_request(MMDSSlaveRequest*)+0x148) [0x525718]
 4: (MDS::_dispatch(Message*)+0x2508) [0x4b9b28]
 5: (MDS::ms_dispatch(Message*)+0x5b) [0x4ba3fb]
 6: (SimpleMessenger::dispatch_entry()+0x89a) [0x48955a]
 7: (SimpleMessenger::DispatchThread::entry()+0x1c) [0x48222c]
 8: (()+0x68ba) [0x7f07be4968ba]
 9: (clone()+0x6d) [0x7f07bd12b02d]
 ceph version 0.25-298-g157e6bd (commit:157e6bdc52aac6aa00a84edbd596ff49fe60e086)
 1: (Server::handle_slave_rename_prep(MDRequest*)+0x1b9c) [0x51fe2c]
 2: (Server::dispatch_slave_request(MDRequest*)+0x32b) [0x5252eb]
 3: (Server::handle_slave_request(MMDSSlaveRequest*)+0x148) [0x525718]
 4: (MDS::_dispatch(Message*)+0x2508) [0x4b9b28]
 5: (MDS::ms_dispatch(Message*)+0x5b) [0x4ba3fb]
 6: (SimpleMessenger::dispatch_entry()+0x89a) [0x48955a]
 7: (SimpleMessenger::DispatchThread::entry()+0x1c) [0x48222c]
 8: (()+0x68ba) [0x7f07be4968ba]
 9: (clone()+0x6d) [0x7f07bd12b02d]
*** Caught signal (Aborted) **
 in thread 0x7f07bbe41710
 ceph version 0.25-298-g157e6bd (commit:157e6bdc52aac6aa00a84edbd596ff49fe60e086)
 1: ./cmds() [0x7180ac]
 2: (()+0xef60) [0x7f07be49ef60]
 3: (gsignal()+0x35) [0x7f07bd08e165]
 4: (abort()+0x180) [0x7f07bd090f70]
 5: (__gnu_cxx::__verbose_terminate_handler()+0x115) [0x7f07bd921dc5]
 6: (()+0xcb166) [0x7f07bd920166]
 7: (()+0xcb193) [0x7f07bd920193]
 8: (()+0xcb28e) [0x7f07bd92028e]
 9: (ceph::__ceph_assert_fail(char const*, char const*, int, char const*)+0x373) [0x6fed43]
 10: (Server::handle_slave_rename_prep(MDRequest*)+0x1b9c) [0x51fe2c]
 11: (Server::dispatch_slave_request(MDRequest*)+0x32b) [0x5252eb]
 12: (Server::handle_slave_request(MMDSSlaveRequest*)+0x148) [0x525718]
 13: (MDS::_dispatch(Message*)+0x2508) [0x4b9b28]
 14: (MDS::ms_dispatch(Message*)+0x5b) [0x4ba3fb]
 15: (SimpleMessenger::dispatch_entry()+0x89a) [0x48955a]
 16: (SimpleMessenger::DispatchThread::entry()+0x1c) [0x48222c]
 17: (()+0x68ba) [0x7f07be4968ba]
 18: (clone()+0x6d) [0x7f07bd12b02d]

Based on the log output we're (not) getting, it looks like path_traverse is failing out in one of the "return -ESTALE" paths. :/


Related issues

Related to Ceph - Bug #859: Ceph does not pass fsstress Resolved 03/04/2011

History

#1 Updated by Greg Farnum over 8 years ago

  • Status changed from New to Duplicate

My browser bugged out; accidentally created two. :(

Also available in: Atom PDF