Project

General

Profile

Bug #859

Ceph does not pass fsstress

Added by Greg Farnum almost 9 years ago. Updated over 8 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
% Done:

100%

Source:
Tags:
Backport:
Regression:
Severity:
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

So far we haven't gotten Ceph to successfully run the Linux Test Project's fsstress test. A typical run for us looks like so:

/usr/lib/ltp/testcases/bin/fsstress -d . -l 1 -n 1000 -p 10 -v

This bug exists to serve as an umbrella bug for all the issues we pick up on.


Subtasks

Tasks #860: mds rstat assert failure on fsstressResolvedGreg Farnum

fs - Subtask #879: Implement function to check fragstat and rstat on CDirsResolvedGreg Farnum

fs - Tasks #861: handle_client_rename thinks nonexistent dir is in subtree mapResolved

fs - Tasks #862: cap_refs[CEPH_CAP_FILE_BUFFER] isn't cleared if truncation zaps changesResolvedGreg Farnum

Tasks #863: osd spinning during fsstressResolvedSamuel Just


Related issues

Related to Ceph - Bug #910: Multi-MDS Ceph does not pass fsstress Resolved 03/22/2011
Related to Ceph - Bug #911: Multi-MDS Ceph does not pass fsstress Duplicate

History

#1 Updated by Greg Farnum almost 9 years ago

  • Target version set to v0.25.1

#2 Updated by Greg Farnum almost 9 years ago

  • Status changed from New to In Progress

Well, I got it to finish a run-through while testing my cfuse fix. Still need to reproduce and debug the rstat issue, but it seems to be more intermittent.

#3 Updated by Sage Weil over 8 years ago

  • Target version changed from v0.25.1 to v0.25.2

#4 Updated by Sage Weil over 8 years ago

  • translation missing: en.field_position set to 2

#5 Updated by Sage Weil over 8 years ago

  • translation missing: en.field_story_points set to 2
  • translation missing: en.field_position deleted (3)
  • translation missing: en.field_position set to 3

#6 Updated by Greg Farnum over 8 years ago

  • Status changed from In Progress to Resolved

There are still issues with multi-MDS clusters, but it seems to be passing a single-MDS test now. See #910.

Also available in: Atom PDF