Project

General

Profile

Actions

Bug #56281

closed

crash: RGWHandler_REST_S3Website::retarget(RGWOp*, RGWOp**, optional_yield)

Added by Telemetry Bot almost 2 years ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Target version:
-
% Done:

0%

Source:
Telemetry
Tags:
backport_processed
Backport:
pacific, quincy
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):

ff04a9fa6d70c31895f01c88ed9b9e13c87f44ebd827771a440350ed641e0264


Description

http://telemetry.front.sepia.ceph.com:4000/d/jByk5HaMz/crash-spec-x-ray?orgId=1&var-sig_v2=408af5b632bd6ed608c6485652e309f824873d76d07ef9951a0d651e8e8d021b

Sanitized backtrace:

    RGWHandler_REST_S3Website::retarget(RGWOp*, RGWOp**, optional_yield)
    rgw_process_authenticated(RGWHandler_REST*, RGWOp*&, RGWRequest*, req_state*, optional_yield, rgw::sal::Store*, bool)
    process_request(rgw::sal::Store*, RGWREST*, RGWRequest*, std::basic_string<char, std::char_traits<char>, std::allocator<char> > const&, rgw::auth::StrategyRegistry const&, RGWRestfulIO*, OpsLogSink*, optional_yield, rgw::dmclock::Scheduler*, std::basic_string<char, std::char_traits<char>, std::allocator<char> >*, std::chrono::duration<unsigned long, std::ratio<1l, 1000000000l> >*, std::shared_ptr<RateLimiter>, int*)
    make_fcontext()

Crash dump sample:
{
    "backtrace": [
        "/lib64/libpthread.so.0(+0x12ce0) [0x7fd9b2b60ce0]",
        "(RGWHandler_REST_S3Website::retarget(RGWOp*, RGWOp**, optional_yield)+0x174) [0x7fd9b5d26314]",
        "(rgw_process_authenticated(RGWHandler_REST*, RGWOp*&, RGWRequest*, req_state*, optional_yield, rgw::sal::Store*, bool)+0xebf) [0x7fd9b5878aaf]",
        "(process_request(rgw::sal::Store*, RGWREST*, RGWRequest*, std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > const&, rgw::auth::StrategyRegistry const&, RGWRestfulIO*, OpsLogSink*, optional_yield, rgw::dmclock::Scheduler*, std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> >*, std::chrono::duration<unsigned long, std::ratio<1l, 1000000000l> >*, std::shared_ptr<RateLimiter>, int*)+0x2616) [0x7fd9b587b696]",
        "/lib64/libradosgw.so.2(+0x65a00a) [0x7fd9b57e800a]",
        "/lib64/libradosgw.so.2(+0x65b6b1) [0x7fd9b57e96b1]",
        "/lib64/libradosgw.so.2(+0x65b82c) [0x7fd9b57e982c]",
        "make_fcontext()" 
    ],
    "ceph_version": "17.2.0",
    "crash_id": "2022-05-03T21:41:44.717047Z_44bcf769-0750-4277-a235-934a3382ca4c",
    "entity_name": "client.5d8055e13d87a0e04956cab930144212da52948f",
    "os_id": "centos",
    "os_name": "CentOS Stream",
    "os_version": "8",
    "os_version_id": "8",
    "process_name": "radosgw",
    "stack_sig": "ff04a9fa6d70c31895f01c88ed9b9e13c87f44ebd827771a440350ed641e0264",
    "timestamp": "2022-05-03T21:41:44.717047Z",
    "utsname_machine": "x86_64",
    "utsname_release": "5.13.0-40-generic",
    "utsname_sysname": "Linux",
    "utsname_version": "#45-Ubuntu SMP Tue Mar 29 14:48:14 UTC 2022" 
}


Related issues 4 (0 open4 closed)

Has duplicate rgw - Bug #53913: rgw: s3website crashes after upgrade from octopus to pacificDuplicateDaniel Gryniewicz

Actions
Has duplicate rgw - Bug #57251: rgw daemons have recently crashed Duplicate

Actions
Copied to rgw - Backport #56653: quincy: crash: RGWHandler_REST_S3Website::retarget(RGWOp*, RGWOp**, optional_yield)ResolvedCory SnyderActions
Copied to rgw - Backport #56654: pacific: crash: RGWHandler_REST_S3Website::retarget(RGWOp*, RGWOp**, optional_yield)ResolvedCory SnyderActions
Actions #1

Updated by Telemetry Bot almost 2 years ago

  • Crash signature (v1) updated (diff)
  • Crash signature (v2) updated (diff)
  • Affected Versions v17.2.0 added
Actions #2

Updated by Daniel Gryniewicz almost 2 years ago

  • Status changed from New to Duplicate

This is a duplicate of the fixed issue https://tracker.ceph.com/issues/56029

Actions #3

Updated by Seena Fallah almost 2 years ago

This is not a duplication of the swift API issue
This should fix with https://github.com/ceph/ceph/pull/46933

Actions #4

Updated by Yaarit Hatuka almost 2 years ago

  • Status changed from Duplicate to Fix Under Review
  • Pull request ID set to 46933

Do we need to backport this to Quincy?

Actions #5

Updated by Seena Fallah almost 2 years ago

I saw the bug on both pacific and quincy
This was a regression came from https://github.com/ceph/ceph/commit/2598e062d04d7fe4477aa096c19ebebfa77d19ea

Actions #6

Updated by Yaarit Hatuka almost 2 years ago

  • Backport set to pacific, quincy

ok, I updated the Backport field accordingly.

Actions #7

Updated by Daniel Gryniewicz almost 2 years ago

  • Status changed from Fix Under Review to Duplicate

This is a duplicate of the already fixed issue https://tracker.ceph.com/issues/56029

Actions #9

Updated by Daniel Gryniewicz almost 2 years ago

  • Status changed from Duplicate to New

Oops, that was swift, this is S3.

Actions #10

Updated by Daniel Gryniewicz almost 2 years ago

  • Status changed from New to Fix Under Review
Actions #11

Updated by Casey Bodley over 1 year ago

  • Has duplicate Bug #53913: rgw: s3website crashes after upgrade from octopus to pacific added
Actions #12

Updated by Cory Snyder over 1 year ago

  • Status changed from Fix Under Review to Pending Backport
Actions #13

Updated by Cory Snyder over 1 year ago

  • Copied to Backport #56653: quincy: crash: RGWHandler_REST_S3Website::retarget(RGWOp*, RGWOp**, optional_yield) added
Actions #14

Updated by Cory Snyder over 1 year ago

  • Copied to Backport #56654: pacific: crash: RGWHandler_REST_S3Website::retarget(RGWOp*, RGWOp**, optional_yield) added
Actions #15

Updated by Backport Bot over 1 year ago

  • Tags set to backport_processed
Actions #16

Updated by Casey Bodley over 1 year ago

  • Has duplicate Bug #57251: rgw daemons have recently crashed added
Actions #17

Updated by Casey Bodley over 1 year ago

  • Status changed from Pending Backport to Resolved
Actions

Also available in: Atom PDF