Project

General

Profile

Actions

Bug #47947

closed

mgr/dashboard: the user can't disable modules in Manager Modules page

Added by Kiefer Chang over 3 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
% Done:

0%

Source:
Community (dev)
Tags:
Backport:
Regression:
Yes
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

This was spotted when working on backport #47943.
Users should be able to disable an enabled and non-always-on module. The disable action is not allowed:

Also, the reason why it's not allowed is not displayed (the following figure shows the correct one):


Files

Screenshot_20201022_144405.png (35 KB) Screenshot_20201022_144405.png Kiefer Chang, 10/22/2020 08:52 AM
Screenshot_20201022_163348.png (14.2 KB) Screenshot_20201022_163348.png Kiefer Chang, 10/22/2020 08:54 AM
Actions #1

Updated by Kiefer Chang over 3 years ago

  • Status changed from In Progress to Fix Under Review
  • Pull request ID set to 37753
Actions #2

Updated by Ernesto Puerta over 3 years ago

Is this a regression? Doesn't it apply to Octopus/Nautilus as well?

Actions #3

Updated by Lenz Grimmer over 3 years ago

  • Status changed from Fix Under Review to Resolved
  • Target version set to v16.0.0
Actions #4

Updated by Ernesto Puerta almost 3 years ago

  • Project changed from mgr to Dashboard
Actions

Also available in: Atom PDF