Project

General

Profile

Bug #46253

OSD specs without service_id

Added by Sebastian Wagner over 1 year ago. Updated 26 days ago.

Status:
Fix Under Review
Priority:
High
Category:
cephadm/osd
Target version:
-
% Done:

0%

Source:
Tags:
low-hanging-fruit
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

Jun 17 16:18:29 monitor1 bash[22660]: cephadm 2020-06-17T14:18:28.313311+0000 mgr.monitor1.jczcyf (mgr.14168) 259 : cephadm [INF] Found osd claims -> {}
Jun 17 16:18:29 monitor1 bash[22660]: cephadm 2020-06-17T14:18:28.313503+0000 mgr.monitor1.jczcyf (mgr.14168) 260 : cephadm [INF] Found osd claims for drivegroup None -> {}
Jun 17 16:18:29 monitor1 bash[22660]: cephadm 2020-06-17T14:18:28.316541+0000 mgr.monitor1.jczcyf (mgr.14168) 261 : cephadm [INF] Applying None on host osd-node1...
Jun 17 16:18:29 monitor1 bash[22660]: cephadm 2020-06-17T14:18:28.317509+0000 mgr.monitor1.jczcyf (mgr.14168) 262 : cephadm [INF] Applying None on host osd-node5...
Jun 17 16:18:29 monitor1 bash[22660]: cephadm 2020-06-17T14:18:28.318438+0000 mgr.monitor1.jczcyf (mgr.14168) 263 : cephadm [INF] Applying None on host osd-node4...
Jun 17 16:18:29 monitor1 bash[22660]: cephadm 2020-06-17T14:18:28.318811+0000 mgr.monitor1.jczcyf (mgr.14168) 264 : cephadm [INF] Applying None on host osd-node2...
Jun 17 16:18:29 monitor1 bash[22660]: cephadm 2020-06-17T14:18:28.319505+0000 mgr.monitor1.jczcyf (mgr.14168) 265 : cephadm [INF] Applying None on host osd-node3...

Related issues

Related to Orchestrator - Bug #46175: cephadm: orch apply -i: MON and MGR service specs must not have a service_id Resolved
Duplicated by Orchestrator - Bug #49755: OSD service is not found Can't reproduce

History

#1 Updated by Sebastian Wagner over 1 year ago

  • Related to Bug #46175: cephadm: orch apply -i: MON and MGR service specs must not have a service_id added

#2 Updated by Stephan Müller about 1 year ago

  • Assignee set to Stephan Müller

#3 Updated by Stephan Müller about 1 year ago

Currently I only get an error running an OSD spec without any service_id.

I will now mute the traceback and just shown that the service_id is missing.

Here is what currently happens:

# cat /tmp/osds_without_service_id 
service_type: osd
placement:
  host_pattern: "osd*" 
data_devices:
  all: true

# ceph orch apply -i /tmp/osds_without_service_id   
Error EINVAL: Traceback (most recent call last):
  File "/ceph/src/pybind/mgr/mgr_module.py", line 1177, in _handle_command
    return self.handle_command(inbuf, cmd)
  File "/ceph/src/pybind/mgr/orchestrator/_interface.py", line 138, in handle_command
    return dispatch[cmd['prefix']].call(self, cmd, inbuf)
  File "/ceph/src/pybind/mgr/mgr_module.py", line 317, in call
    return self.func(mgr, **kwargs)
  File "/ceph/src/pybind/mgr/orchestrator/_interface.py", line 100, in <lambda>
    wrapper_copy = lambda *l_args, **l_kwargs: wrapper(*l_args, **l_kwargs)
  File "/ceph/src/pybind/mgr/orchestrator/_interface.py", line 89, in wrapper
    return func(*args, **kwargs)
  File "/ceph/src/pybind/mgr/orchestrator/module.py", line 1183, in _apply_misc
    raise_if_exception(completion)
  File "/ceph/src/pybind/mgr/orchestrator/_interface.py", line 658, in raise_if_exception
    raise e
Exception: Cannot add Service: id required

#4 Updated by Sebastian Wagner 11 months ago

  • Category changed from cephadm to cephadm/osd

#5 Updated by Sebastian Wagner 8 months ago

  • Assignee deleted (Stephan Müller)

#6 Updated by Juan Miguel Olmo Martínez 8 months ago

  • Assignee set to Juan Miguel Olmo Martínez

#7 Updated by Sebastian Wagner 7 months ago

  • Assignee deleted (Juan Miguel Olmo Martínez)

#8 Updated by Sebastian Wagner 7 months ago

  • Duplicated by Bug #49755: OSD service is not found added

#9 Updated by Sebastian Wagner 26 days ago

  • Status changed from New to Fix Under Review
  • Assignee set to Sebastian Wagner
  • Pull request ID set to 42905

Also available in: Atom PDF