Project

General

Profile

Bug #46175

cephadm: orch apply -i: MON and MGR service specs must not have a service_id

Added by Nathan Cutler 3 months ago. Updated about 1 month ago.

Status:
Resolved
Priority:
High
Category:
cephadm
Target version:
% Done:

0%

Source:
Tags:
low-hanging-fruit ux
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

service_spec_core.yml

---
service_type: mon
service_id: sesdev_mon_deployment
placement:
    hosts:
        - 'node1'
        - 'node2'
        - 'node3'
---
service_type: mgr
service_id: sesdev_mgr_deployment
placement: 
    hosts: 
        - 'node1'
        - 'node2'
        - 'node3'

Result:

master:~ # ceph orch ls --service-type mon --format json-pretty 

[
  {
    "placement": {
      "hosts": [
        {
          "hostname": "node1",
          "name": "",
          "network": "" 
        },
        {
          "hostname": "node2",
          "name": "",
          "network": "" 
        },
        {
          "hostname": "node3",
          "name": "",
          "network": "" 
        }
      ]
    },
    "service_id": "sesdev_mon_deployment",
    "service_name": "mon.sesdev_mon_deployment",
    "service_type": "mon",
    "status": {
      "running": 0,
      "size": 3
    }
  },
  {
    "placement": {
      "hosts": [
        {
          "hostname": "node2",
          "name": "",
          "network": "" 
        }
      ]
    },
    "service_id": "sesdev_mon_deployment.node2",
    "service_name": "mon.sesdev_mon_deployment.node2",
    "service_type": "mon",
    "status": {
      "container_image_id": "mix",
      "container_image_name": "mix",
      "last_refresh": "2020-06-24T11:30:40.499595",
      "running": 3,
      "size": 0
    },
    "unmanaged": true
  }
]
master:~ # ceph orch ls --service-type mgr --format json-pretty   

[
  {
    "placement": {
      "hosts": [
        {
          "hostname": "node1",
          "name": "",
          "network": "" 
        },
        {
          "hostname": "node2",
          "name": "",
          "network": "" 
        },
        {
          "hostname": "node3",
          "name": "",
          "network": "" 
        }
      ]
    },
    "service_id": "sesdev_mgr_deployment",
    "service_name": "mgr.sesdev_mgr_deployment",
    "service_type": "mgr",
    "status": {
      "running": 0,
      "size": 3
    }
  },
  {
    "placement": {
      "hosts": [
        {
          "hostname": "node2",
          "name": "",
          "network": "" 
        }
      ]
    },
    "service_id": "sesdev_mgr_deployment.node2.usqbyy",
    "service_name": "mgr.sesdev_mgr_deployment.node2.usqbyy",
    "service_type": "mgr",
    "status": {
      "container_image_id": "a2c23ec01b1e6cf7168acdac917de31c122a0fc1f71b59124e8a585c398a07a2",
      "container_image_name": "registry.opensuse.org/filesystems/ceph/octopus/upstream/images/ceph/ceph:latest",
      "last_refresh": "2020-06-24T11:30:40.500111",
      "running": 4,
      "size": 0
    },
    "unmanaged": true
  }
]

(Yes, I got 4 MGRs instead of 3, but that's a different known issue.)


Related issues

Related to Orchestrator - Cleanup #46219: cephadm: remove DaemonDescription.service_id() New
Related to Orchestrator - Bug #46253: OSD specs without service_id New

History

#1 Updated by Sebastian Wagner 3 months ago

  • Priority changed from Normal to High

#2 Updated by Nathan Cutler 3 months ago

If this is caused by the presence of "service_id: SOME_STRING" in the spec yaml, maybe it would make sense for cephadm to simply ignore service_id for MON and MGR?

#3 Updated by Nathan Cutler 3 months ago

  • Subject changed from Day 1 deployment from service spec YAML results in bogus MON and MGR services to Day 1 deployment from service spec YAML results in bogus MON and MGR services if service_id specified for MON/MGR

#4 Updated by Sebastian Wagner 3 months ago

Nathan Cutler wrote:

If this is caused by the presence of "service_id: SOME_STRING" in the spec yaml, maybe it would make sense for cephadm to simply ignore service_id for MON and MGR?

definitively!

#5 Updated by Sebastian Wagner 3 months ago

  • Subject changed from Day 1 deployment from service spec YAML results in bogus MON and MGR services if service_id specified for MON/MGR to cephadm: orch apply -i: MON and MGR service specs must not have a service_id
  • Tags set to low-hanging-fruit ux

#6 Updated by Sebastian Wagner 3 months ago

  • Category set to cephadm

#7 Updated by Sebastian Wagner 3 months ago

  • Related to Cleanup #46219: cephadm: remove DaemonDescription.service_id() added

#8 Updated by Sebastian Wagner 3 months ago

  • Related to Bug #46253: OSD specs without service_id added

#9 Updated by Michael Fritch 3 months ago

  • Assignee set to Michael Fritch

#10 Updated by Michael Fritch 3 months ago

  • Status changed from New to Fix Under Review
  • Pull request ID set to 35839

#11 Updated by Sebastian Wagner about 1 month ago

  • Status changed from Fix Under Review to Resolved
  • Target version set to v15.2.5

Also available in: Atom PDF