Project

General

Profile

Bug #45407

cephadm: Speed up OSD deployment preview

Added by Lenz Grimmer 5 months ago. Updated 4 months ago.

Status:
Resolved
Priority:
High
Assignee:
-
Category:
cephadm
Target version:
% Done:

0%

Source:
Tags:
ux
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

There is a pending Ceph Dashboard pull request to implement a "preview" feature for deploying new OSDs.

Currently, this feature can not be merged, as the process of generating the preview is very slow and does not scale on a cluster with lots of nodes and disks, which would severely impact the user experience as timeout errors may occur while the Dashboard is waiting for the result to be computed.

A solution needs to be found on how to accelerate this preview generation step.


Related issues

Related to mgr - Feature #42453: mgr/dashboard: Allow previewing OSDs in Create OSD from Fix Under Review

History

#1 Updated by Lenz Grimmer 5 months ago

  • Related to Feature #42453: mgr/dashboard: Allow previewing OSDs in Create OSD from added

#2 Updated by Sebastian Wagner 5 months ago

  • Priority changed from Normal to High

#3 Updated by Sebastian Wagner 5 months ago

  • Tags set to ux

#4 Updated by Joshua Schmid 5 months ago

  • Status changed from New to Fix Under Review
  • Pull request ID set to 35084

#5 Updated by Sebastian Wagner 4 months ago

  • Status changed from Fix Under Review to Resolved
  • Target version set to v15.2.4

#6 Updated by Kiefer Chang 4 months ago

PR https://github.com/ceph/ceph/pull/34665 won't be beneficial from the preview cache implemented in this issue, because Dashboard users submit a new managed OSDSpec each time.

Also available in: Atom PDF