Project

General

Profile

Bug #42076

mgr/dashboard: remove rotates column in inventory device list

Added by Kiefer Chang 10 months ago. Updated 8 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
dashboard/general
Target version:
% Done:

0%

Source:
Tags:
low-hanging-fruit
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

In the device list (e.g. https://tracker.ceph.com/attachments/download/4328/01-hosts-inventory.png) there is already a type column. We can drop the rotates column.
This is a suggestion from OSD creation flow discussion (https://tracker.ceph.com/issues/40335#note-12)


Related issues

Related to mgr - Feature #40335: mgr/dashboard: Create OSD on spare disks Resolved

History

#1 Updated by Lenz Grimmer 10 months ago

  • Related to Feature #40335: mgr/dashboard: Create OSD on spare disks added

#2 Updated by Kiefer Chang 9 months ago

I prefer not to hide rotates column for now because:

#3 Updated by Lenz Grimmer 9 months ago

Kiefer Chang wrote:

I prefer not to hide rotates column for now because:

Good point. As they seem related, would it make sense to combine both the type and rotational flag in one column then?

#4 Updated by Ernesto Puerta 9 months ago

Kiefer Chang wrote:

I prefer not to hide rotates column for now because:

Punch card readers would be non-rotational and are/were slower than HDDs. And, NVME is a controller/interface technology; the underlying medium is still solid-state.

I can understand that "rotational" might make sense for kernel developers regarding physical data seeking and queuing policies (https://github.com/torvalds/linux/commit/1308835ffffe6d61ad1f48c5c381c9cc47f683ec), but I always found it weird/misguiding to expose it from a user perspective. The property has_shell of Animal is good hint for their slowness metric, but Slugs or Sloths are have_shell = false and yet slow (perhaps it is the "Sl-" thing).

I'd be in favor of HDD/SDD over rotation/non-rotational for indicating IO/latency performance.

#5 Updated by Ricardo Marques 8 months ago

  • Target version set to v15.0.0

#6 Updated by Volker Theile 8 months ago

  • Status changed from New to Resolved
  • Pull request ID set to 30921

Also available in: Atom PDF