Project

General

Profile

Bug #41314

mgr/dashboard: Editing RGW bucket fails because of name is already in use

Added by Patrick Seidensal over 1 year ago. Updated about 1 year ago.

Status:
Pending Backport
Priority:
Normal
Assignee:
Category:
dashboard/rgw
Target version:
% Done:

0%

Source:
Tags:
usability
Backport:
nautilus
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

When editing an RGW bucket, the only field that can be changed is `Owner`.

When the owner is changed to `-- Select a user --` and the `Edit Bucket` button is clicked, the form says that the owner is a required field. By ignoring that and re-clicking `Edit Bucket`, the form adds an additional error, saying that `The chosen name is already in use` below the `Name` field, although the name can not be changed. As far as I can tell, the latter validation error can not be fixed without reloading the page.

validation-error-rgw-bucket-edit.png View (42.1 KB) Patrick Seidensal, 08/16/2019 02:29 PM


Related issues

Related to mgr - Fix #41180: mgr/dashboard: fix bucket operations with tenant after new bucket utilities implementation New
Copied to mgr - Backport #41916: nautilus: mgr/dashboard: Editing RGW bucket fails because of name is already in use New

History

#1 Updated by Alfonso Martínez over 1 year ago

  • Related to Fix #41180: mgr/dashboard: fix bucket operations with tenant after new bucket utilities implementation added

#2 Updated by Volker Theile over 1 year ago

  • Status changed from New to In Progress
  • Assignee set to Volker Theile

#3 Updated by Volker Theile over 1 year ago

  • Status changed from In Progress to Fix Under Review
  • Backport set to nautilus
  • Affected Versions v14.2.3 added

#4 Updated by Volker Theile over 1 year ago

  • Pull request ID set to 29767

#5 Updated by Volker Theile about 1 year ago

  • Status changed from Fix Under Review to Resolved

#6 Updated by Volker Theile about 1 year ago

  • Status changed from Resolved to Pending Backport

#7 Updated by Nathan Cutler about 1 year ago

  • Copied to Backport #41916: nautilus: mgr/dashboard: Editing RGW bucket fails because of name is already in use added

#8 Updated by Lenz Grimmer about 1 year ago

  • Target version set to v15.0.0

Also available in: Atom PDF