Project

General

Profile

Bug #41305

mgr/dashboard: dashboard tests fail on e2e tests

Added by Kiefer Chang about 1 month ago. Updated about 1 month ago.

Status:
Duplicate
Priority:
High
Assignee:
-
Category:
dashboard/qa
Target version:
-
Start date:
08/16/2019
Due date:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

Currently, ceph dashboard tests on github PRs is failing because of e2e test failure.

**************************************************
*                    Failures                    *
**************************************************

1) RGW users page create, edit & delete user test should create user
  - Failed: Wait timed out after 10000ms

2) RGW users page create, edit & delete user test should edit users full name, email and max buckets
  - Failed: Wait timed out after 10008ms

3) RGW users page create, edit & delete user test should delete user
  - Failed: Wait timed out after 10008ms

4) RGW users page Invalid input test should put invalid input into user creation form and check fields are marked invalid
  - Failed: Wait timed out after 10004ms

5) RGW users page Invalid input test should put invalid input into user edit form and check fields are marked invalid
  - Failed: Wait timed out after 10003ms

Executed 71 of 71 specs (5 FAILED) in 2 mins 22 secs.

Some failing jenkins jobs:
https://jenkins.ceph.com/job/ceph-dashboard-pull-requests/1119/console
https://jenkins.ceph.com/job/ceph-dashboard-pull-requests/1117/console
https://jenkins.ceph.com/job/ceph-dashboard-pull-requests/1116/console

consoleText.txt View (642 KB) Kiefer Chang, 08/16/2019 05:51 AM


Related issues

Duplicates rgw - Bug #41300: AssertionError in radosgw-admin-rest task Resolved 08/15/2019

History

#1 Updated by Kiefer Chang about 1 month ago

some finding so far:

bin/radosgw-admin user list
[
    "56789abcdef0123456789abcdef0123456789abcdef0123456789abcdef01234",
    "testx$9876543210abcdef0123456789abcdef0123456789abcdef0123456789abcdef",
    "0123456789abcdef0123456789abcdef0123456789abcdef0123456789abcdef",
    "0123456789abcdef0123456789abcdef0123456789abcdef0123456789abcdef.buckets",  <---
    "dev.buckets",       <----
    "test",
    "testid",
    "dev" 
]

  • When navigating to page Object Gateway -> Users in `users.e2e-spec.ts`, frontend gets user list from backend and gets information for every user. If we get information for a user whose uid is ended with .buckets, there will be an error. And the e2e tests fail with timeout because the page continues waiting for result.

#2 Updated by Kiefer Chang about 1 month ago

I also used s3cmd to test RGW behavior. If <user> create a bucket, a new user called <user>.buckets is also automatically created.

#3 Updated by Lenz Grimmer about 1 month ago

  • Status changed from New to Duplicate

Duplicate of #41300 (RGW regression)

#4 Updated by Lenz Grimmer about 1 month ago

  • Duplicates Bug #41300: AssertionError in radosgw-admin-rest task added

Also available in: Atom PDF