Project

General

Profile

Bug #41059

mgr/dashboard: ceph dashboard Jenkins job fails due to webdriver error: "session not created: Chrome version must be between 71 and 75"

Added by Laura Paduano about 2 months ago. Updated about 2 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
dashboard/qa
Target version:
-
Start date:
08/02/2019
Due date:
% Done:

0%

Source:
Q/A
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

When we install google-chrome-stable on the system it would install google-chrome-stable-76.0.3809.87-1.x86_64
There's also a related upstream issue: https://github.com/angular/webdriver-manager/issues/404
and a PR to fix this has been merged already: https://github.com/angular/webdriver-manager/pull/405 (webdriver-manager version bump to 12.1.6)
but we're still facing this issue (seems like protractor needs to be updated upstream due to https://github.com/angular/webdriver-manager/pull/405,
see: https://github.com/angular/protractor/issues/5289 and https://github.com/DSpace/dspace-angular/issues/445)

What we have in our package-lock.json:
"webdriver-manager": "^12.0.6"

Tried to bump the protractor version to 6.0.0 (since it's no longer beta) https://github.com/ceph/ceph/pull/29426
But this would fail with a different error:

Cannot automatically find webdriver-manager to update.
Update webdriver-manager manually and run 'ng e2e --no-webdriver-update' instead.
Error: Cannot automatically find webdriver-manager to update.
Update webdriver-manager manually and run 'ng e2e --no-webdriver-update' instead.

Seems to be related to https://github.com/angular/protractor/issues/5209

Some more output from Jenkins:
npm list webdriver-manager:
/home/jenkins-build/build/workspace/ceph-dashboard-pull-requests/src/pybind/mgr/dashboard/frontend
└─┬
└──

while "npm info webdriver-manager" points to the tarball webdriver-manager-12.1.6.tgz


Related issues

Copied to mgr - Bug #41075: nautilus: mgr/dashboard: ceph dashboard Jenkins job fails due to webdriver error: "session not created: Chrome version must be between 71 and 75" Resolved 08/02/2019

History

#1 Updated by Laura Paduano about 2 months ago

  • Pull request ID set to 29426

#2 Updated by Laura Paduano about 2 months ago

  • Description updated (diff)

#3 Updated by Laura Paduano about 2 months ago

  • Description updated (diff)

#4 Updated by Laura Paduano about 2 months ago

  • Description updated (diff)

#5 Updated by Laura Paduano about 2 months ago

  • Status changed from New to Need Review
  • Assignee set to Tiago Melo
  • Pull request ID changed from 29426 to 28343

#6 Updated by Tiago Melo about 2 months ago

  • Copied to Bug #41075: nautilus: mgr/dashboard: ceph dashboard Jenkins job fails due to webdriver error: "session not created: Chrome version must be between 71 and 75" added

#7 Updated by Tiago Melo about 2 months ago

  • Status changed from Need Review to Resolved

Also available in: Atom PDF