Project

General

Profile

Bug #41059

Updated by Laura Paduano 3 months ago

When we install google-chrome-stable on the system it would install google-chrome-stable-76.0.3809.87-1.x86_64
There's also a related upstream issue: https://github.com/angular/webdriver-manager/issues/404
and a PR to fix this has been merged already: https://github.com/angular/webdriver-manager/pull/405 (webdriver-manager version bump to 12.1.6)
but we're still facing this issue (seems like protractor needs to be updated upstream due to https://github.com/angular/webdriver-manager/pull/405, issue.
see: https://github.com/angular/protractor/issues/5289

What we have in our package-lock.json:
"webdriver-manager": "^12.0.6"

Tried to bump the protractor version to 6.0.0 (since it's no longer beta) https://github.com/ceph/ceph/pull/29426
But this would fail with a different error: with:
<pre><code class="text">
Cannot automatically find webdriver-manager to update.
Update webdriver-manager manually and run 'ng e2e --no-webdriver-update' instead.
Error: Cannot automatically find webdriver-manager to update.
Update webdriver-manager manually and run 'ng e2e --no-webdriver-update' instead.
</code></pre>

Seems to be related to https://github.com/angular/protractor/issues/5209

Back