Project

General

Profile

Bug #41075

nautilus: mgr/dashboard: ceph dashboard Jenkins job fails due to webdriver error: "session not created: Chrome version must be between 71 and 75"

Added by Tiago Melo 3 months ago. Updated 2 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
dashboard/qa
Target version:
Start date:
08/02/2019
Due date:
% Done:

0%

Source:
Q/A
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

When we install google-chrome-stable on the system it would install google-chrome-stable-76.0.3809.87-1.x86_64
There's also a related upstream issue: https://github.com/angular/webdriver-manager/issues/404
and a PR to fix this has been merged already: https://github.com/angular/webdriver-manager/pull/405 (webdriver-manager version bump to 12.1.6)
but we're still facing this issue (seems like protractor needs to be updated upstream due to https://github.com/angular/webdriver-manager/pull/405,
see: https://github.com/angular/protractor/issues/5289 and https://github.com/DSpace/dspace-angular/issues/445)

What we have in our package-lock.json:
"webdriver-manager": "^12.0.6"

Tried to bump the protractor version to 6.0.0 (since it's no longer beta) https://github.com/ceph/ceph/pull/29426
But this would fail with a different error:

Cannot automatically find webdriver-manager to update.
Update webdriver-manager manually and run 'ng e2e --no-webdriver-update' instead.
Error: Cannot automatically find webdriver-manager to update.
Update webdriver-manager manually and run 'ng e2e --no-webdriver-update' instead.

Seems to be related to https://github.com/angular/protractor/issues/5209

Some more output from Jenkins:
npm list webdriver-manager:
/home/jenkins-build/build/workspace/ceph-dashboard-pull-requests/src/pybind/mgr/dashboard/frontend
└─┬
└──

while "npm info webdriver-manager" points to the tarball webdriver-manager-12.1.6.tgz


Related issues

Copied from mgr - Bug #41059: mgr/dashboard: ceph dashboard Jenkins job fails due to webdriver error: "session not created: Chrome version must be between 71 and 75" Resolved 08/02/2019

History

#1 Updated by Tiago Melo 3 months ago

  • Copied from Bug #41059: mgr/dashboard: ceph dashboard Jenkins job fails due to webdriver error: "session not created: Chrome version must be between 71 and 75" added

#2 Updated by Tiago Melo 3 months ago

The fix that was commited to master can't be backported since the packages have diverged between master and nautilus.
For this reason I created a new, non backport, issue for this bug.

#3 Updated by Tiago Melo 3 months ago

  • Status changed from New to Need Review
  • Pull request ID set to 29491

#4 Updated by Tiago Melo 2 months ago

  • Status changed from Need Review to Resolved

#5 Updated by Nathan Cutler 2 months ago

https://github.com/ceph/ceph/pull/29491
merge commit 4d9848f739fe0e129ced9f3ba198b079446d2806 (v14.2.2-306-g4d9848f739)

Also available in: Atom PDF