Project

General

Profile

Bug #40753

Tasks #36451: mgr/dashboard: Scalability testing

mgr/dashboard: Perform scalability tests with large amounts of RGW buckets

Added by Lenz Grimmer over 1 year ago. Updated about 1 month ago.

Status:
Resolved
Priority:
Urgent
Category:
dashboard/rgw
Target version:
% Done:

0%

Source:
Tags:
scalability
Backport:
nautilus, octopus
Regression:
No
Severity:
1 - critical
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

Evaluate the performance of the dashboard with increasing sizes of RGW buckets to identify potential bottlenecks and performance improvements.


Related issues

Related to rgw - Feature #22168: The RGW Admin OPS is missing the ability to filter for e.g. buckets and users New 11/20/2017
Related to mgr - Bug #47543: mgr/dashboard: fix performance issue when listing large amounts of buckets Resolved
Copied to mgr - Tasks #40766: mgr/dashboard: Perform scalability tests with large amounts of RGW users New 07/12/2019

History

#1 Updated by Lenz Grimmer over 1 year ago

  • Copied to Tasks #40766: mgr/dashboard: Perform scalability tests with large amounts of RGW users added

#2 Updated by Ernesto Puerta 4 months ago

  • Tracker changed from Tasks to Bug
  • Status changed from New to In Progress
  • Assignee set to Ernesto Puerta
  • Priority changed from Normal to Urgent
  • Target version changed from v15.0.0 to v16.0.0
  • Tags set to scalability
  • Backport set to nautilus, octopus
  • Regression set to No
  • Severity set to 1 - critical

This has been reproduced in downstream (nautilus based) with more than 2k buckets and real network conditions, and basically renders RGW Bucket management unusable. Given that RGW bucket hasn't changed too much since Nautilus, this will likely be reproducible in upstream. I will try to.

Good news is that the back-end works and return the whole 2k list of buckets. Front-end reports net::ERR_INSUFFICIENT_RESOURCES, so this might be due to the front-end launching many requests in parallel for each bucket.

#3 Updated by Volker Theile 4 months ago

The problem here is that the RGW Admin OPS API does not support filters and pagination. Because of that the Dashboard RGW controller need to retrieve ALL buckets, bypass them to the UI which then does the filtering.

I created an tracker issue looooong time ago that the Admin OPS API requires that feature: https://tracker.ceph.com/issues/22168

#4 Updated by Lenz Grimmer 4 months ago

  • Related to Feature #22168: The RGW Admin OPS is missing the ability to filter for e.g. buckets and users added

#5 Updated by Ernesto Puerta 4 months ago

Volker Theile wrote:

The problem here is that the RGW Admin OPS API does not support filters and pagination. Because of that the Dashboard RGW controller need to retrieve ALL buckets, bypass them to the UI which then does the filtering.

I created an tracker issue looooong time ago that the Admin OPS API requires that feature: https://tracker.ceph.com/issues/22168

Thanks for the context, Volker!

#6 Updated by Alfonso Martínez 4 months ago

  • Related to Bug #47543: mgr/dashboard: fix performance issue when listing large amounts of buckets added

#7 Updated by Ernesto Puerta about 1 month ago

  • Status changed from In Progress to Resolved

Also available in: Atom PDF