Project

General

Profile

Bug #40428

mgr/dashboard: controllers/grafana is not Python 3 compatible

Added by Sebastian Wagner 5 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
Normal
Category:
dashboard/backend
Target version:
Start date:
06/19/2019
Due date:
% Done:

0%

Source:
Development
Tags:
Backport:
nautilus
Regression:
No
Severity:
3 - minor
Reviewed:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

mypy revealed:

+pybind/mgr/dashboard/controllers/grafana.py: note: In member "dashboards" of class "Grafana":
+pybind/mgr/dashboard/controllers/grafana.py:39: error: "Exception" has no attribute "message" 

This looks like a real issue.


Related issues

Copied to mgr - Backport #40846: nautilus: mgr/dashboard: controllers/grafana is not Python 3 compatible Resolved

History

#1 Updated by Patrick Seidensal 5 months ago

  • Assignee set to Patrick Seidensal

#2 Updated by Lenz Grimmer 5 months ago

  • Backport set to nautilus
  • Affected Versions v14.2.0, v14.2.1, v15.0.0 added

#3 Updated by Patrick Seidensal 4 months ago

  • Status changed from New to In Progress

#4 Updated by Patrick Seidensal 4 months ago

  • Status changed from In Progress to Need Review
  • Pull request ID set to 28956

#5 Updated by Patrick Seidensal 4 months ago

  • Status changed from Need Review to Pending Backport

#6 Updated by Nathan Cutler 4 months ago

  • Copied to Backport #40846: nautilus: mgr/dashboard: controllers/grafana is not Python 3 compatible added

#7 Updated by Ricardo Marques 3 months ago

  • Status changed from Pending Backport to Resolved
  • Target version set to v15.0.0

Also available in: Atom PDF