Project

General

Profile

Bug #39650

mgr/dashboard: Pool graph/sparkline points do not display the correct values

Added by Patrick Seidensal 6 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
Normal
Category:
dashboard/pools
Target version:
Start date:
05/09/2019
Due date:
% Done:

0%

Source:
Tags:
Backport:
nautilus
Regression:
Yes
Severity:
3 - minor
Reviewed:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

When hovering with the cursor over the points displayed in the graphs of pools, the values displayed are always the same for each point. In addition to that, the values displayed seem to be wrong, too. I cannot explain why there's so much traffic on a RBD of my test cluster, although I didn't do anything that would explain that. The latter problem was also initially reported by mrf3.



Provided by mrf3:

2.png View (39.3 KB) Patrick Seidensal, 05/09/2019 01:33 PM

1.png View (46 KB) Patrick Seidensal, 05/09/2019 01:33 PM

3.png View (40.8 KB) Patrick Seidensal, 05/09/2019 01:33 PM

a08534bba146c30623932eb85a80e3b0.png View (8.98 KB) Patrick Seidensal, 05/09/2019 01:36 PM


Related issues

Copied to mgr - Backport #40658: nautilus: mgr/dashboard: Pool graph/sparkline points do not display the correct values Resolved

History

#1 Updated by Patrick Seidensal 6 months ago

  • Description updated (diff)

#2 Updated by Patrick Seidensal 6 months ago

  • Subject changed from mgr/dashboard: Pool graph points do not display the correct values to mgr/dashboard: Pool graph/sparkline points do not display the correct values

#3 Updated by Lenz Grimmer 6 months ago

  • Assignee set to Stephan Müller

#4 Updated by Lenz Grimmer 6 months ago

I think the key point is that the values "Read bytes" and "Write bytes" are simple incrementing counters that display the total amount of data that has been read and written from/to a specific pool. So this is a number that is constantly increasing - I'm not sure if the current charts really provide a useful visualization here.

I think it would be much better to replace that graph with a value in human-readable units (not plain bytes) and rather replace the values displayed in the following columns (Read ops and write ops) with such a chart, as they are more likely to vary over short time periods (and it would provide much more valuable insight to have a time series of data here to visualize an drastic increase or decrease in any of these).

Thoughts?

#5 Updated by Lenz Grimmer 6 months ago

  • Tags set to usability, monitoring
  • Backport set to nautilus
  • Affected Versions v14.2.1, v15.0.0 added

#6 Updated by Stephan Müller 6 months ago

  • Status changed from New to In Progress

#7 Updated by Stephan Müller 6 months ago

I investigated it, it's not a bug as everything is working as intended.

This problem has 2 aspects that should be discussed here.

But before that I will light the shadow by concluding what happened here. There were minor changes going on that were less than 0.1 MB. Because they were happening chart wanted to indicated that a increase is going on.

So back to the two aspects, first aspect the chart shows even small changes. The second aspect, the tooltip only shows changes that a big enough depending on the dimension you are in.

Their are multiple ways to proceed from here.
Solution one would be to use a bigger precision in the label. But this also has the side effect that if the number is big enough you won't see small changes even if the chart reflects it.

The better solution tow is, to only show changes in the number, as read and write bytes will only increase it would be better to show sparks instead. Which we are already doing in the OSD page.

Hm... I thought this would not end up like a monologue, but as we already doing the alignment of the points on the OSD page, I will implement the same in the pools page.

#8 Updated by Stephan Müller 6 months ago

  • Status changed from In Progress to Need Review
  • Pull request ID set to 28153

#9 Updated by Lenz Grimmer 4 months ago

  • Status changed from Need Review to Pending Backport
  • Target version set to v15.0.0

#10 Updated by Nathan Cutler 4 months ago

  • Copied to Backport #40658: nautilus: mgr/dashboard: Pool graph/sparkline points do not display the correct values added

#11 Updated by Stephan Müller 4 months ago

  • Blocks Backport #39604: mgr/dashboard: Allow the decrease of pg's of an existing pool added

#12 Updated by Stephan Müller 4 months ago

  • Blocks deleted (Backport #39604: mgr/dashboard: Allow the decrease of pg's of an existing pool)

#13 Updated by Ricardo Marques 3 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF