Project

General

Profile

Bug #39613

mgr/dashboard: misplaced objects not shown anymore

Added by Patrick Seidensal 4 months ago. Updated 2 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
dashboard/monitoring
Target version:
Start date:
05/07/2019
Due date:
% Done:

0%

Source:
Tags:
Backport:
nautilus
Regression:
Yes
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

On Ceph Mimic, the dashboard showed the misplaced objects on the dashboard page in the health section.

On Ceph Nautilus, the dashboard page has changed and the status of misplaced objects isn't displayed on the dashboard page anymore. A suggestions of erimar77 was to show them when the user clicks on "Objects", which currently only displays the amount of objects but nothing about their state.


Related issues

Copied to mgr - Backport #40189: nautilus: mgr/dashboard: misplaced objects not shown anymore Resolved

History

#1 Updated by Alfonso MH 4 months ago

In Mimic this warning was enabled by default, but not in nautilus:

http://docs.ceph.com/docs/master/releases/nautilus/#changelog

"By default, Ceph no longer issues a health warning when there are misplaced objects (objects that are fully replicated but not stored on the intended OSDs). You can reenable the old warning by setting mon_warn_on_misplaced to true."

If this warning is reenabled, it will be shown in dashboard when you click on "HEALTH_WARN" (Cluster Status card) and in "Logs" menu.

#2 Updated by Patrick Seidensal 4 months ago

If the user enables that feature and the cluster of that user is in state `HEALTH_OK`, but it has some misplaced objects, the landing page won't allow the user to see that value by clicking on`HEALTH_OK`. I tend to show it elsewhere, like suggested by erimar77.

#3 Updated by Alfonso MH 4 months ago

  • Status changed from New to In Progress
  • Assignee set to Alfonso MH

#4 Updated by Alfonso MH 3 months ago

  • Status changed from In Progress to Need Review
  • Backport set to nautilus

#5 Updated by Lenz Grimmer 3 months ago

  • Pull request ID set to 28104

#6 Updated by Lenz Grimmer 3 months ago

  • Status changed from Need Review to Pending Backport
  • Target version set to v15.0.0

#7 Updated by Nathan Cutler 3 months ago

  • Copied to Backport #40189: nautilus: mgr/dashboard: misplaced objects not shown anymore added

#9 Updated by Lenz Grimmer 2 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF