Project

General

Profile

Bug #38408

rgw: marker is not advanced during garbage collection

Added by J. Eric Ivancich almost 4 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
High
Target version:
% Done:

0%

Source:
Tags:
Backport:
mimic, luminous
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

This can cause no forward GC progress to be made under certain rare circumstances.


Related issues

Copied to rgw - Backport #38752: luminous: rgw: marker is not advanced during garbage collection Rejected
Copied to rgw - Backport #38753: mimic: rgw: marker is not advanced during garbage collection Rejected

History

#1 Updated by J. Eric Ivancich almost 4 years ago

  • Pull request ID set to 26545

#2 Updated by Nathan Cutler almost 4 years ago

  • Project changed from Ceph to rgw

#3 Updated by Casey Bodley almost 4 years ago

  • Status changed from In Progress to 7

#4 Updated by Casey Bodley over 3 years ago

  • Priority changed from Normal to High

#5 Updated by Casey Bodley over 3 years ago

  • Status changed from 7 to Pending Backport

#6 Updated by Nathan Cutler over 3 years ago

  • Copied to Backport #38752: luminous: rgw: marker is not advanced during garbage collection added

#7 Updated by Nathan Cutler over 3 years ago

  • Copied to Backport #38753: mimic: rgw: marker is not advanced during garbage collection added

#8 Updated by Nathan Cutler about 3 years ago

  • Status changed from Pending Backport to Resolved
  • Backport deleted (mimic,luminous)

Pull request 26545 is a subset of PR 26601. In other words, when I try to cherry-pick the commit in PR 26545 after backporting the one in 26601, the cherry-pick is empty.

Since that is potentially confusing to backporters, let's handle the backporting via #38454

#9 Updated by Nathan Cutler about 3 years ago

  • Backport set to mimic, luminous

Also available in: Atom PDF