Project

General

Profile

Bug #38055

rgw: GET/HEAD and PUT operations on buckets w/lifecycle expiration configured do not return x-amz-expiration header

Added by Matt Benjamin almost 4 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority:
High
Assignee:
Target version:
% Done:

0%

Source:
Tags:
Backport:
luminous mimic nautilus
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):


Related issues

Copied to rgw - Backport #41122: nautilus: rgw: GET/HEAD and PUT operations on buckets w/lifecycle expiration configured do not return x-amz-expiration header Resolved
Copied to rgw - Backport #41123: luminous: rgw: GET/HEAD and PUT operations on buckets w/lifecycle expiration configured do not return x-amz-expiration header Rejected
Copied to rgw - Backport #41124: mimic: rgw: GET/HEAD and PUT operations on buckets w/lifecycle expiration configured do not return x-amz-expiration header Rejected

History

#1 Updated by Matt Benjamin almost 4 years ago

  • Status changed from In Progress to Fix Under Review

#2 Updated by Casey Bodley almost 4 years ago

  • Status changed from Fix Under Review to 17

#3 Updated by Casey Bodley over 3 years ago

  • Status changed from 17 to In Progress

#4 Updated by Casey Bodley over 3 years ago

  • Status changed from In Progress to 7

#5 Updated by Casey Bodley over 3 years ago

  • Status changed from 7 to Pending Backport
  • Backport set to luminous mimic nautilus

@Matt, do all 3 backports sound appropriate to you?

#6 Updated by Patrick Donnelly over 3 years ago

  • Copied to Backport #41122: nautilus: rgw: GET/HEAD and PUT operations on buckets w/lifecycle expiration configured do not return x-amz-expiration header added

#7 Updated by Patrick Donnelly over 3 years ago

  • Copied to Backport #41123: luminous: rgw: GET/HEAD and PUT operations on buckets w/lifecycle expiration configured do not return x-amz-expiration header added

#8 Updated by Patrick Donnelly over 3 years ago

  • Copied to Backport #41124: mimic: rgw: GET/HEAD and PUT operations on buckets w/lifecycle expiration configured do not return x-amz-expiration header added

#9 Updated by Nathan Cutler over 3 years ago

  • Pull request ID set to 26160

#10 Updated by Nathan Cutler almost 3 years ago

@Casey The backports do not seem appropriate, because @Matt 's fix uses the "fmt" submodule, which was added post-nautilus. Can you confirm or deny that theory?

#11 Updated by Nathan Cutler almost 2 years ago

  • Status changed from Pending Backport to Resolved

While running with --resolve-parent, the script "backport-create-issue" noticed that all backports of this issue are in status "Resolved" or "Rejected".

Also available in: Atom PDF