Project

General

Profile

Actions

Bug #38044

closed

implement --version flag

Added by Joshua Schmid about 5 years ago. Updated 5 months ago.

Status:
Won't Fix
Priority:
Normal
Target version:
-
% Done:

0%

Source:
Community (dev)
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

As c-v is versioned separately, it'd be nice to have an easy way to query it's version.


Related issues 1 (0 open1 closed)

Related to ceph-volume - Feature #37082: Split ceph-volume into a separate packageRejected

Actions
Actions #1

Updated by Alfredo Deza about 5 years ago

it is actually not versioned separately (although that was the intent in the beginning), it is now assumed that the version is whatever the Ceph version is.

We recently removed the flag because it was tied to something different (1.0.0 I think?)

Actions #2

Updated by Joshua Schmid about 5 years ago

Alfredo Deza wrote:

it is actually not versioned separately (although that was the intent in the beginning), it is now assumed that the version is whatever the Ceph version is.

We recently removed the flag because it was tied to something different (1.0.0 I think?)

yes, it was installed with the 1.0.0 suffix. Maybe c-v should return ceph's version string instead?

Actions #3

Updated by Alfredo Deza about 5 years ago

That might be tricky to get right, unless we kind of proxy to `ceph --version` ? Not sure how much value I see on this. Is there anything specific you are trying to solve or is this a "nice to have" ?

Actions #4

Updated by Joshua Schmid about 5 years ago

Alfredo Deza wrote:

That might be tricky to get right, unless we kind of proxy to `ceph --version` ? Not sure how much value I see on this. Is there anything specific you are trying to solve or is this a "nice to have" ?

Nah, just a nice to have.

Actions #5

Updated by Rishabh Dave over 4 years ago

If what is being requested on tracker issue #37082 is sane/appropriate/right, then the idea of reusing the version number from "ceph -v" can't be used.

Actions #6

Updated by Jan Fajerski over 4 years ago

hmm not necessarily, we could still mirror cephs version scheme and steps...

Actions #7

Updated by Sebastian Wagner almost 3 years ago

  • Status changed from New to Fix Under Review
  • Assignee set to Sebastian Wagner
  • Pull request ID set to 42048
Actions #8

Updated by Sebastian Wagner almost 3 years ago

  • Related to Feature #37082: Split ceph-volume into a separate package added
Actions #9

Updated by Konstantin Shalygin 5 months ago

  • Status changed from Fix Under Review to Won't Fix
  • Target version deleted (v14.0.0)
Actions

Also available in: Atom PDF