Project

General

Profile

Bug #23458

java compile error: Source/Target option 1.5 is not supported since jdk 9

Added by Shengjing Zhu about 2 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
java
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
luminous
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

error: Source option 1.5 is no longer supported. Use 1.6 or later.
error: Target option 1.5 is no longer supported. Use 1.6 or later.

With the release of jdk 9(which now the default in Debian testing/unstable), Source/Target option 1.5 is not supported.

http://openjdk.java.net/jeps/182

Not sure is there any better way than hard code the version. JEP 182 suggests since jdk 9:

JDK 9 will implement a "one plus three back" support policy meaning that 1.9/9, 1.8/8, 1.7/7, and 1.6/6 will be recognized in that release. That policy will continue in JDK 10.


Related issues

Copied to Ceph - Backport #24043: luminous: java compile error: Source/Target option 1.5 is not supported since jdk 9 Resolved

History

#2 Updated by Brad Hubbard about 2 years ago

  • Status changed from New to Resolved

#3 Updated by Kefu Chai about 2 years ago

  • Copied to Backport #24043: luminous: java compile error: Source/Target option 1.5 is not supported since jdk 9 added

#4 Updated by Kefu Chai about 2 years ago

  • Status changed from Resolved to Pending Backport
  • Backport set to luminous

#5 Updated by Ken Dreyer almost 2 years ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF