Project

General

Profile

Bug #9555

msg/Pipe.cc: 1513: FAILED assert(0 == "old msgs despite reconnect_seq feature") (firefly)

Added by Samuel Just about 4 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Category:
-
Target version:
-
Start date:
09/21/2014
Due date:
% Done:

0%

Source:
Q/A
Tags:
Backport:
firefly
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

firefly

/a/samuelj-2014-09-20_19:00:23-rados-wip-sam-testing-firefly2-wip-testing-old-vanilla-basic-multi/501749/remote/ceph-osd.4.log

wip-sam-testing-firefly2 (no messenger patches)

Associated revisions

Revision 847e5e10 (diff)
Added by Sage Weil almost 4 years ago

osd: check that source OSD is valid for MOSDRepScrub

Make sure the message we got from the peer OSD is valid. Specifically,
this avoids a race like this:

- A marks down B
- B sends MOSDRepScrub
- A accepts connection from B as new
- A replies to scrub
- B crashes because msgr seq 1 < expected seq 1000+

See #8880 for the most recent fix for requests.

Fixes: #9555
Backport: giant, firefly
Signed-off-by: Sage Weil <>

Revision eb03e792 (diff)
Added by Sage Weil over 3 years ago

osd: check that source OSD is valid for MOSDRepScrub

Make sure the message we got from the peer OSD is valid. Specifically,
this avoids a race like this:

- A marks down B
- B sends MOSDRepScrub
- A accepts connection from B as new
- A replies to scrub
- B crashes because msgr seq 1 < expected seq 1000+

See #8880 for the most recent fix for requests.

Fixes: #9555
Backport: giant, firefly
Signed-off-by: Sage Weil <>
(cherry picked from commit 847e5e102522d651aa9687a54aaafcebf3afc596)

Conflicts:
src/osd/OSD.cc: require functions first argument is now a reference

History

#1 Updated by Sage Weil about 4 years ago

  • Subject changed from msg/Pipe.cc: 1513: FAILED assert(0 == "old msgs despite reconnect_seq feature") to msg/Pipe.cc: 1513: FAILED assert(0 == "old msgs despite reconnect_seq feature") (firefly)
  • Source changed from other to Q/A

#2 Updated by Samuel Just about 4 years ago

  • Priority changed from Urgent to High

#3 Updated by Sage Weil almost 4 years ago

  • Status changed from New to In Progress
  • Assignee set to Sage Weil
  • Priority changed from High to Urgent

ubuntu@teuthology:/a/teuthology-2014-12-12_02:32:02-rados-giant-distro-basic-multi/651682

#4 Updated by Sage Weil almost 4 years ago

  • Status changed from In Progress to Need Review

#5 Updated by Greg Farnum almost 4 years ago

  • Status changed from Need Review to Pending Backport

#7 Updated by Loic Dachary over 3 years ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF