Project

General

Profile

Bug #36633

mgr/dashboard: No module named jwt

Added by Volker Theile about 1 month ago. Updated about 1 month ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
dashboard/backend
Target version:
Start date:
10/30/2018
Due date:
% Done:

0%

Source:
Development
Tags:
Backport:
Regression:
Yes
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

It is not possible to start the Ceph Mgr dashboard module in latest master (including https://github.com/ceph/ceph/pull/22833).

Python JWT packages are installed and it is possible to import it in the Python console.

arrakis /ceph/build # ceph mgr module enable dashboard
*** DEVELOPER MODE: setting PATH, PYTHONPATH and LD_LIBRARY_PATH ***
2018-10-30 15:24:56.929 7f7fbd7b7700 -1 WARNING: all dangerous and experimental features are enabled.
2018-10-30 15:24:56.961 7f7fbd7b7700 -1 WARNING: all dangerous and experimental features are enabled.
Error ENOENT: module 'dashboard' reports that it cannot run on the active manager daemon: No module named 'jwt' (pass --force to force enablement)
arrakis /ceph/build # python -V
Python 2.7.15

arrakis /ceph/build # zypper search PyJWT
Loading repository data...
Reading installed packages...

S  | Name          | Summary                                 | Type   
---+---------------+-----------------------------------------+--------
i+ | python2-PyJWT | JSON Web Token implementation in Python | package
   | python3-PyJWT | JSON Web Token implementation in Python | package

arrakis /ceph/build # python
Python 2.7.15 (default, May 21 2018, 17:53:03) [GCC] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import jwt
>>> 

Related issues

Related to mgr - Bug #36653: 'sudo yum -y install ceph-mgr' failed New 10/31/2018

History

#1 Updated by Ricardo Dias about 1 month ago

Did you build ceph-mgr with python 3?

#2 Updated by Volker Theile about 1 month ago

Yes i did: -DWITH_PYTHON3=ON -DWITH_PYTHON2=OFF -DMGR_PYTHON_VERSION=3 -DWITH_TESTS=ON -DWITH_CCACHE=ON

#3 Updated by Ricardo Dias about 1 month ago

Volker Theile wrote:

Yes i did: -DWITH_PYTHON3=ON -DWITH_PYTHON2=OFF -DMGR_PYTHON_VERSION=3 -DWITH_TESTS=ON -DWITH_CCACHE=ON

That is the reason. You only have the python2-PyJWT package installed. You have to install the python3-PyJWT package.

#4 Updated by Volker Theile about 1 month ago

You're right, did miss the 'i+' in fron of the Python3 package. Arghhh.

Opened a pull request for the docker container: https://github.com/ricardoasmarques/ceph-dev-docker/pull/33

#5 Updated by Ricardo Dias about 1 month ago

  • Status changed from New to Closed

#6 Updated by Nathan Cutler about 1 month ago

  • Related to Bug #36653: 'sudo yum -y install ceph-mgr' failed added

Also available in: Atom PDF