Project

General

Profile

Bug #22836

ceph-volume doesn't add OSD's auth to Monitors when creating new BlueStore OSD

Added by pei jia over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
-
Start date:
01/31/2018
Due date:
% Done:

0%

Source:
Tags:
Backport:
luminous
Regression:
No
Severity:
2 - major
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

When add new BlueStore OSD with ceph-volume command, the new OSD daemon fails to start with log

_get_class not permitted to load kvs
_get_class not permitted to load lua
_get_class not permitted to load sdk
...
log_to_monitors {default=true}
init authentication failed: (1) Operation not permitted
.
After checking the ceph-volume command log, it turns out that it doesn't contain "ceph auth add osd.{osd-num} osd 'allow *' mon 'allow rwx' -i /var/lib/ceph/osd/osd.id/keyring".
If we use "ceph auth add ..." manually, the new OSD daemon will start correctly.

ceph-volume command log.txt View (4.27 KB) pei jia, 01/31/2018 02:31 AM


Related issues

Copied to ceph-volume - Backport #22924: luminous: ceph-volume doesn't add OSD's auth to Monitors when creating new BlueStore OSD Resolved

History

#1 Updated by Alfredo Deza over 1 year ago

  • Status changed from New to Need More Info

We can't replicate this issue when deploying OSDs. Do you have some configuration that requires these permissions? Without them, in our tests, the OSD starts up without problems.

You are right that ceph-volume will not add an 'allow rwx' to the keyring.

#2 Updated by Andrew Schoen over 1 year ago

I believe this bug is because of the use of --osd-id. This PR fixes the issue where auth is not created for an OSD if --osd-id is used: https://github.com/ceph/ceph/pull/20203

#3 Updated by Ken Dreyer over 1 year ago

  • Status changed from Need More Info to Pending Backport
  • Assignee set to Andrew Schoen
  • Backport set to luminous

#4 Updated by Ken Dreyer over 1 year ago

  • Copied to Backport #22924: luminous: ceph-volume doesn't add OSD's auth to Monitors when creating new BlueStore OSD added

#5 Updated by Andrew Schoen over 1 year ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF