Project

General

Profile

Bug #22361

balancer crush-compat sends "foo" command

Added by Dan van der Ster over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
12/11/2017
Due date:
% Done:

0%

Source:
Community (user)
Tags:
Backport:
luminous
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

Hi,
I'm playing with the crush-compat balancer in 12.2.2, and it sends "foo" commands to the rest api:

2017-12-11 10:37:41.551009 7f224fc20700  1 mgr[balancer] Handling command: '{'prefix': 'balancer reset', 'target': ['mgr', '']}'
2017-12-11 10:37:41.551058 7f224fc20700  1 mgr.server reply handle_command (0) Success
2017-12-11 10:37:43.013382 7f226f370700  1 mgr send_beacon active
2017-12-11 10:37:45.018345 7f226f370700  1 mgr send_beacon active
2017-12-11 10:37:46.077190 7f224fc20700  1 mgr[restful] Unknown request ''
2017-12-11 10:37:46.079389 7f224fc20700  1 mgr[restful] Unknown request ''
2017-12-11 10:37:47.022583 7f226f370700  1 mgr send_beacon active
2017-12-11 10:37:47.132307 7f224fc20700  1 mgr[restful] Unknown request 'foo'
2017-12-11 10:37:47.132486 7f224fc20700  1 mgr[restful] Unknown request 'foo'
2017-12-11 10:37:47.132841 7f224fc20700  1 mgr[restful] Unknown request 'foo'
2017-12-11 10:37:47.132941 7f224fc20700  1 mgr[restful] Unknown request 'foo'
2017-12-11 10:37:47.133106 7f224fc20700  1 mgr[restful] Unknown request 'foo'
...

Those seem to come from balancer/module.py, e.g.

result = CommandResult('foo')
            self.send_command(result, 'mon', '', json.dumps({
                'prefix': 'osd crush weight-set reweight-compat',
                'format': 'json',
                'item': 'osd.%d' % osd,
                'weight': [weight],
            }), 'foo')

Cheers, Dan


Related issues

Copied to mgr - Backport #22455: luminous: balancer crush-compat sends "foo" command Resolved

History

#1 Updated by Greg Farnum over 1 year ago

  • Project changed from Ceph to mgr

#2 Updated by John Spray over 1 year ago

  • Status changed from New to Need Review

https://github.com/ceph/ceph/pull/19482

This is a harmless bit of noise: when mgr modules send commands to the mon, they can set a string tag on them. In this instance the balancer module was using "foo" in a couple of places. They're getting echoed by the restful module because the mgr currently isn't smart enough to only send command completion notifications to the module that started the command, so other modules might complain about them while dropping them.

#3 Updated by John Spray over 1 year ago

  • Backport set to luminous

#4 Updated by Kefu Chai over 1 year ago

  • Status changed from Need Review to Pending Backport

#5 Updated by Nathan Cutler over 1 year ago

  • Copied to Backport #22455: luminous: balancer crush-compat sends "foo" command added

#6 Updated by John Spray over 1 year ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF