Project

General

Profile

Bug #18333

rgw: Realm set does not create a new period

Added by Wido den Hollander 10 months ago. Updated 4 months ago.

Status:
Resolved
Priority:
Normal
Target version:
-
Start date:
12/22/2016
Due date:
% Done:

0%

Source:
Community (user)
Tags:
rgw,realm,radosgw-admin
Backport:
jewel, kraken
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Release:
Needs Doc:
No

Description

When importing a realm from a JSON file using 'realm set' a period is not created.

root@alpha:~# radosgw-admin realm set --infile backup/realm.json
{
    "id": "58612f93191c0b6b82c0cbeccc77cde8",
    "name": "gn.zm1",
    "current_period": "",
    "epoch": 0
}
root@alpha:~# cat backup/realm.json 
{
    "id": "58612f93191c0b6b82c0cbeccc77cde8",
    "name": "gn.zm1" 
}

root@alpha:~#

This leads to no period being present.

When trying to prepare for a new period this fails:

root@alpha:~# radosgw-admin period prepare
could not init realm : (2) No such file or directory
root@alpha:~#

When you supply the ID of the realm it seems to work, but it doesn't.

root@alpha:~# radosgw-admin period update
Error initializing realm (2) No such file or directory
root@alpha:~# radosgw-admin period update --realm-id=58612f93191c0b6b82c0cbeccc77cde8
period init failed: (2) No such file or directory
2016-12-22 13:01:17.799324 7f95dcadba00  1 error read_lastest_epoch .rgw.root:periods..latest_epoch
2016-12-22 13:01:17.799338 7f95dcadba00  0 failed to use_latest_epoch period id  realm  id 58612f93191c0b6b82c0cbeccc77cde8 : (2) No such file or directory
root@alpha:~#

To me this seems broken, since this works:

- Create new realm
- Change realm ID in zonegroup and zone JSON files
- Import zonegroup and zone from JSON files

This was tested against version 10.2.5


Related issues

Copied to rgw - Backport #18498: jewel: rgw: Realm set does not create a new period Resolved
Copied to rgw - Backport #18499: kraken: rgw: Realm set does not create a new period Resolved

History

#1 Updated by Orit Wasserman 10 months ago

  • Status changed from New to Need Review

#2 Updated by Yehuda Sadeh 10 months ago

  • Backport set to jewel

#3 Updated by Casey Bodley 9 months ago

  • Status changed from Need Review to Pending Backport
  • Backport changed from jewel to jewel, kraken

#4 Updated by Loic Dachary 9 months ago

  • Copied to Backport #18498: jewel: rgw: Realm set does not create a new period added

#5 Updated by Loic Dachary 9 months ago

  • Copied to Backport #18499: kraken: rgw: Realm set does not create a new period added

#6 Updated by Nathan Cutler 4 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF