Project

General

Profile

Bug #18161

kernel client failing to look up mds_namespace gives ENOENT (but it exists)

Added by John Spray 6 months ago. Updated 4 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
fs/ceph
Target version:
-
Start date:
12/06/2016
Due date:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Release:
Needs Doc:
No

Description

See this failure:
http://pulpito.ceph.com/jspray-2016-12-06_12:37:38-kcephfs:recovery-master-testing-basic-smithi/611135

The client is getting the FSMapUser as we can see in the mon log:

2016-12-06 14:30:01.582024 7f07e8a13700  1 -- 172.21.15.1:6789/0 --> 172.21.15.95:0/1525586736 -- fsmap.user(e 45) v1 -- 0x564acc13d000 con 0

...but it's giving an ENOENT when trying to look up the mds_namespace 'alpha'

2016-12-06T14:30:01.563 INFO:teuthology.orchestra.run.smithi095:Running: 'sudo adjust-ulimits ceph-coverage /home/ubuntu/cephtest/archive/coverage /sbin/mount.ceph 172.21.15.1:6789:/ /home/ubuntu/cephtest/mnt.0 -v -o name=0,secretfile=/home/ubuntu/cephtest/ceph.data/client.0.secret,mds_namespace=alpha'
2016-12-06T14:30:01.663 INFO:teuthology.orchestra.run.smithi095.stdout:parsing options: name=0,secretfile=/home/ubuntu/cephtest/ceph.data/client.0.secret,mds_namespace=alpha
2016-12-06T14:30:01.663 INFO:teuthology.orchestra.run.smithi095.stdout:ceph: Unknown mount option mds_namespace
2016-12-06T14:30:01.663 INFO:teuthology.orchestra.run.smithi095.stdout:mount error 2 = No such file or directory

(The 'unknown mount option' seems unrelated http://tracker.ceph.com/issues/18159 -- we can be certain that the option is making it to the kernel because it only subscribes to fsmap.user when mds_namespace is set)

History

#1 Updated by Zheng Yan 6 months ago

can't reproduce this manually. maybe the -ENOENT was from mds up check, please try adding 'norequire_active_mds' mount option

#2 Updated by John Spray 6 months ago

Ah, that could be it. I'll look again.

#3 Updated by John Spray 5 months ago

  • Status changed from New to Resolved

Yep, that was it, I've added the norequire_active_mds option.

#6 Updated by Ilya Dryomov 4 months ago

  • Status changed from Testing to Resolved
  • Assignee set to Zheng Yan

Also available in: Atom PDF