Project

General

Profile

Bug #12157

RGW Swift API: responses for several request types don't contain mandatory Content-Type header

Added by Radoslaw Zarzynski over 3 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Normal
Target version:
-
Start date:
06/25/2015
Due date:
% Done:

0%

Source:
Q/A
Tags:
Backport:
firefly,hammer
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

Swift sends Content-Type HTTP header for all requests even if the response doesn't contain body (in other words: if Content-Length is zero). We have this behaviour implemented until applying some changes in end_header() function. Unfortunately, lack of the header causes early exists of many Tempest's tests for verification of conformance with OpenStack Object Storage API v1.


Related issues

Related to rgw - Bug #12095: RGW Swift API: response for HEAD on container doesn't contain mandatory Content-Type header Duplicate 06/19/2015
Copied to rgw - Backport #12246: RGW Swift API: responses for several request types don't contain mandatory Content-Type header Resolved 06/25/2015
Copied to rgw - Backport #13360: RGW Swift API: responses for several request types don't contain mandatory Content-Type header Resolved

Associated revisions

Revision 106aeba2 (diff)
Added by Radoslaw Zarzynski over 3 years ago

rgw: enforce Content-Type in Swift responses.

Swift sends Content-Type HTTP header even if the response
doesn't contain body. We have this behaviour implemented
until applying some changes in end_header() function.
Unfortunately, lack of Content-Type causes early exits in
many Tempest's tests for Swift API verification.

Fixes: #12157
Signed-off-by: Radoslaw Zarzynski <>

Revision b8aafbc6 (diff)
Added by Radoslaw Zarzynski about 3 years ago

rgw: enforce Content-Type in Swift responses.

Swift sends Content-Type HTTP header even if the response
doesn't contain body. We have this behaviour implemented
until applying some changes in end_header() function.
Unfortunately, lack of Content-Type causes early exits in
many Tempest's tests for Swift API verification.

Fixes: #12157
Signed-off-by: Radoslaw Zarzynski <>
(cherry picked from commit 106aeba206736d4080326f9bc191876bed63370b)

Revision c9226afd (diff)
Added by Radoslaw Zarzynski about 3 years ago

rgw: enforce Content-Type in Swift responses.

Swift sends Content-Type HTTP header even if the response
doesn't contain body. We have this behaviour implemented
until applying some changes in end_header() function.
Unfortunately, lack of Content-Type causes early exits in
many Tempest's tests for Swift API verification.

Fixes: #12157
Signed-off-by: Radoslaw Zarzynski <>
(cherry picked from commit 106aeba206736d4080326f9bc191876bed63370b)

History

#1 Updated by Radoslaw Zarzynski over 3 years ago

  • Status changed from New to In Progress
  • Assignee set to Radoslaw Zarzynski

#2 Updated by Radoslaw Zarzynski over 3 years ago

  • Status changed from In Progress to Need Review

#3 Updated by Yehuda Sadeh over 3 years ago

  • Status changed from Need Review to Pending Backport
  • Backport set to hammer

#4 Updated by Yehuda Sadeh over 3 years ago

Commit:106aeba206736d4080326f9bc191876bed63370b

#5 Updated by Abhishek Lekshmanan over 3 years ago

For the backport, it looks like a couple of other commits (https://github.com/ceph/ceph/pull/4418 & https://github.com/ceph/ceph/pull/4361 ) need to be backported before this is landed. Can Radoslaw/Yehuda confirm this is the case?

#7 Updated by Loic Dachary about 3 years ago

Appears to also be fixed by https://github.com/ceph/ceph/pull/5041

#8 Updated by Nathan Cutler about 3 years ago

  • Backport changed from hammer to firefly,hammer

#9 Updated by Nathan Cutler about 3 years ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF