Project

General

Profile

Bug #12095

RGW Swift API: response for HEAD on container doesn't contain mandatory Content-Type header

Added by Radoslaw Zarzynski about 4 years ago. Updated almost 4 years ago.

Status:
Duplicate
Priority:
Normal
Target version:
-
Start date:
06/19/2015
Due date:
% Done:

0%

Source:
Q/A
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

1. RGW via FCGI frontend:
$ curl -i ${publicURL}/cont -X HEAD -H "X-Auth-Token: $token"

HTTP/1.1 204 No Content
Server: nginx/1.4.6 (Ubuntu)
Date: Fri, 19 Jun 2015 13:25:04 GMT
Connection: keep-alive
X-Timestamp: 1434720301.00000
X-Container-Object-Count: 4
X-Container-Bytes-Used: 0
X-Container-Bytes-Used-Actual: 0
X-Storage-Policy: default-placement
X-Trans-Id: ts-default.4123.673-20150619:132504:711

2. Swift:
$ curl -i ${publicURL}/cont -X HEAD -H "X-Auth-Token: $token"

HTTP/1.1 204 No Content
Content-Length: 0
X-Container-Object-Count: 0
Accept-Ranges: bytes
X-Timestamp: 1430929360.03263
X-Container-Bytes-Used: 0
Content-Type: text/plain; charset=utf-8
X-Trans-Id: txa5f7a9224a694db698c8f-00558410ea
Date: Fri, 19 Jun 2015 12:54:02 GMT

It looks we have got a regression regarding the end_header function while fixing #11091 (rgw: shouldn't return content-type: application/xml if content length is 0; commit ID: 5cc92bb27cfbaee4af24dc312c9b98331f899794).


Related issues

Related to rgw - Bug #11091: rgw: shouldn't return content-type: application/xml if content length is 0 Resolved 03/10/2015
Related to rgw - Bug #12157: RGW Swift API: responses for several request types don't contain mandatory Content-Type header Resolved 06/25/2015

History

#1 Updated by Orit Wasserman about 4 years ago

  • Assignee set to Orit Wasserman

#2 Updated by Yehuda Sadeh almost 4 years ago

  • Status changed from New to Duplicate

Duplicate of #12157

Also available in: Atom PDF