Project

General

Profile

Bug #6787

upstart is restarting daemons which we want to be dead

Added by Greg Farnum almost 6 years ago. Updated over 2 years ago.

Status:
Won't Fix
Priority:
High
Assignee:
-
Category:
-
Target version:
-
Start date:
11/15/2013
Due date:
% Done:

0%

Source:
other
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

It looks like upstart's auto service management stuff is restarting OSDs which have committed suicide due to getting EIO.
Joao reported that there are also issues touching on this when monitors get kicked out of quorum while they're in one of the special sets.

We need a good way of dealing with issues like this generically.

History

#1 Updated by Loic Dachary over 5 years ago

#6789 also happens because a mon is restarted automatically by upstart. It's not the only reason though but it seems related.

#2 Updated by Sage Weil over 5 years ago

  • Status changed from New to Verified

#3 Updated by Sage Weil over 2 years ago

  • Status changed from Verified to Won't Fix

Also available in: Atom PDF