Project

General

Profile

Bug #6629

fd cache and external changes to recently-modified files don't behave nicely

Added by Greg Farnum about 6 years ago. Updated over 5 years ago.

Status:
Won't Fix
Priority:
Normal
Assignee:
-
Category:
OSD
Target version:
% Done:

0%

Source:
Community (user)
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

A user reported that they were trying to test pg repair functionality and it did not appear to be restoring files deleted directly from an OSD's data store. It appears that this is because the files in question were still held open by the FD cache, and so transactions to replace them were running into that and modifying the (unlinked) file!
I'm not sure if there's anything we can reasonably do about this in a broad sense, but it would probably make sense to close any file descriptors associated with objects we detect as inconsistent when scrubbing.

History

#1 Updated by Dan Mick about 6 years ago

Maybe we could use inotify to watch for relevant changes to the filestore and close the cached FDs when their files evaporate?

#2 Updated by Samuel Just over 5 years ago

  • Status changed from New to Won't Fix

Also available in: Atom PDF