Project

General

Profile

Bug #639

RHEL6 beta packaging breaks on 'libcls_rbd.so.1.0.0.debug'

Added by Brian Chrisman over 10 years ago. Updated about 10 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

/usr/lib/debug/usr/lib64/rados-classes/libcls_rbd.so.1.0.0.debug is
installed but unpackaged.

In spec file I see this is being touched for a purpose that's not clearly apparent to me.
The path gets mucked up with the usr/lib/debug prepended to usr/lib64.. etc.

ceph.spec.in:80 has an extra usr/lib and should probably be:
mkdir -p $RPM_BUILD_ROOT/%{_libdir}/debug/rados-classes/
touch $RPM_BUILD_ROOT/%{_libdir}/debug/rados-classes/libcls_rbd.so.1.0.0.debug

But if so then this directory and file also need to be identified for packaging.
I'm not sure why this file/directory exists, so I just removed in my build.

History

#1 Updated by Sage Weil over 10 years ago

The purpose of touching it is to prevent the installed .so from being stripped. Which means we don't need it in the debug package. Does this throw a warning or something? That aside it should be working as intended...

#2 Updated by Sage Weil over 10 years ago

  • Target version set to v0.25

#3 Updated by Sage Weil over 10 years ago

  • Target version changed from v0.25 to v0.25.1

#4 Updated by Sage Weil over 10 years ago

  • Assignee set to Colin McCabe

#5 Updated by Sage Weil over 10 years ago

  • Target version changed from v0.25.1 to v0.25.2

#6 Updated by Sage Weil over 10 years ago

  • translation missing: en.field_story_points set to 1
  • translation missing: en.field_position set to 553

Also available in: Atom PDF