Project

General

Profile

Actions

Bug #57303

closed

rados/cephadm: Failed to fetch package version from https://shaman.ceph.com/api/search/?status=ready&project=ceph&flavor=default&distros=ubuntu%2F22.04%2Fx86_64&sha1=b34ca7d1c2becd6090874ccda56ef4cd8dc64bf7

Added by Laura Flores over 1 year ago. Updated 2 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
% Done:

0%

Source:
Tags:
backport_processed
Backport:
quincy,pacific
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

Several occurrences with cephadm tests on this run, such as:

/a/yuriw-2022-08-17_19:34:54-rados-wip-yuri7-testing-2022-08-17-0943-quincy-distro-default-smithi/6977780

2022-08-18T04:53:31.094 DEBUG:teuthology.misc:System to be installed: Ubuntu
2022-08-18T04:53:31.094 INFO:teuthology.task.install.deb:Installing packages: ceph, cephadm, ceph-mds, ceph-mgr, ceph-common, ceph-fuse, ceph-test, ceph-volume, radosgw, python3-rados, python3-rgw, python3-cephfs, python3-rbd, libcephfs2, libcephfs-dev, librados2, librbd1, rbd-fuse on remote deb x86_64
2022-08-18T04:53:31.095 DEBUG:teuthology.packaging:Querying https://shaman.ceph.com/api/search?status=ready&project=ceph&flavor=default&distros=ubuntu%2F22.04%2Fx86_64&sha1=b34ca7d1c2becd6090874ccda56ef4cd8dc64bf7
2022-08-18T04:53:31.357 ERROR:teuthology.contextutil:Saw exception from nested tasks
Traceback (most recent call last):
  File "/home/teuthworker/src/git.ceph.com_git_teuthology_b1d387f12b117399cb87c86aaa341398fa0c0919/teuthology/contextutil.py", line 31, in nested
    vars.append(enter())
  File "/usr/lib/python3.6/contextlib.py", line 81, in __enter__
    return next(self.gen)
  File "/home/teuthworker/src/git.ceph.com_git_teuthology_b1d387f12b117399cb87c86aaa341398fa0c0919/teuthology/task/install/__init__.py", line 218, in install
    install_packages(ctx, package_list, config)
  File "/home/teuthworker/src/git.ceph.com_git_teuthology_b1d387f12b117399cb87c86aaa341398fa0c0919/teuthology/task/install/__init__.py", line 83, in install_packages
    ctx, remote, pkgs[system_type], config)
  File "/home/teuthworker/src/git.ceph.com_git_teuthology_b1d387f12b117399cb87c86aaa341398fa0c0919/teuthology/parallel.py", line 84, in __exit__
    for result in self:
  File "/home/teuthworker/src/git.ceph.com_git_teuthology_b1d387f12b117399cb87c86aaa341398fa0c0919/teuthology/parallel.py", line 98, in __next__
    resurrect_traceback(result)
  File "/home/teuthworker/src/git.ceph.com_git_teuthology_b1d387f12b117399cb87c86aaa341398fa0c0919/teuthology/parallel.py", line 30, in resurrect_traceback
    raise exc.exc_info[1]
  File "/home/teuthworker/src/git.ceph.com_git_teuthology_b1d387f12b117399cb87c86aaa341398fa0c0919/teuthology/parallel.py", line 23, in capture_traceback
    return func(*args, **kwargs)
  File "/home/teuthworker/src/git.ceph.com_git_teuthology_b1d387f12b117399cb87c86aaa341398fa0c0919/teuthology/task/install/deb.py", line 79, in _update_package_list_and_install
    log.info('Pulling from %s', builder.base_url)
  File "/home/teuthworker/src/git.ceph.com_git_teuthology_b1d387f12b117399cb87c86aaa341398fa0c0919/teuthology/packaging.py", line 554, in base_url
    return self._get_base_url()
  File "/home/teuthworker/src/git.ceph.com_git_teuthology_b1d387f12b117399cb87c86aaa341398fa0c0919/teuthology/packaging.py", line 856, in _get_base_url
    self.assert_result()
  File "/home/teuthworker/src/git.ceph.com_git_teuthology_b1d387f12b117399cb87c86aaa341398fa0c0919/teuthology/packaging.py", line 937, in assert_result
    raise VersionNotFoundError(self._result.url)
teuthology.exceptions.VersionNotFoundError: Failed to fetch package version from https://shaman.ceph.com/api/search/?status=ready&project=ceph&flavor=default&distros=ubuntu%2F22.04%2Fx86_64&sha1=b34ca7d1c2becd6090874ccda56ef4cd8dc64bf7

Seems to be an issue fetching packages for Ubuntu Jammy 22.04.


Related issues 2 (0 open2 closed)

Related to CephFS - Bug #57280: qa: tasks/kernel_cfuse_workunits_untarbuild_blogbench fails - Failed to fetch package version from shamanResolvedDhairya Parmar

Actions
Copied to Orchestrator - Backport #57314: quincy: rados/cephadm: Failed to fetch package version from https://shaman.ceph.com/api/search/?status=ready&project=ceph&flavor=default&distros=ubuntu%2F22.04%2Fx86_64&sha1=b34ca7d1c2becd6090874ccda56ef4cd8dc64bf7 ResolvedAdam KingActions
Actions #1

Updated by Laura Flores over 1 year ago

  • Related to Bug #57280: qa: tasks/kernel_cfuse_workunits_untarbuild_blogbench fails - Failed to fetch package version from shaman added
Actions #2

Updated by Laura Flores over 1 year ago

/a/yuriw-2022-08-18_17:36:35-rados-wip-yuri5-testing-2022-08-18-0812-distro-default-smithi/6978841

Actions #3

Updated by Adam King over 1 year ago

  • Status changed from New to Resolved
  • Assignee set to Adam King
  • Pull request ID set to 47674
Actions #4

Updated by Laura Flores over 1 year ago

  • Status changed from Resolved to Pending Backport
  • Backport set to quincy
Actions #5

Updated by Backport Bot over 1 year ago

  • Copied to Backport #57314: quincy: rados/cephadm: Failed to fetch package version from https://shaman.ceph.com/api/search/?status=ready&project=ceph&flavor=default&distros=ubuntu%2F22.04%2Fx86_64&sha1=b34ca7d1c2becd6090874ccda56ef4cd8dc64bf7 added
Actions #6

Updated by Backport Bot over 1 year ago

  • Tags set to backport_processed
Actions #7

Updated by Yaarit Hatuka over 1 year ago

Actions #8

Updated by Adam King over 1 year ago

  • Status changed from Pending Backport to Resolved
Actions #9

Updated by Laura Flores over 1 year ago

  • Status changed from Resolved to New
  • Backport changed from quincy to quincy,pacific

/a/yuriw-2022-09-20_17:39:55-rados-wip-yuri5-testing-2022-09-19-1007-pacific-distro-default-smithi/7039204

@Adam DC949 has this been backported to Pacific? If so, you can mark this back as "Resolved".

Actions #10

Updated by Adam King over 1 year ago

Laura Flores wrote:

/a/yuriw-2022-09-20_17:39:55-rados-wip-yuri5-testing-2022-09-19-1007-pacific-distro-default-smithi/7039204

@Adam DC949 has this been backported to Pacific? If so, you can mark this back as "Resolved".

no, only quincy so far. I hadn't seen this failure in pacific yet so it wasn't backported but I can open one for that

Actions #11

Updated by Adam King over 1 year ago

Laura Flores wrote:

/a/yuriw-2022-09-20_17:39:55-rados-wip-yuri5-testing-2022-09-19-1007-pacific-distro-default-smithi/7039204

@Adam DC949 has this been backported to Pacific? If so, you can mark this back as "Resolved".

I took a closer look at https://pulpito.ceph.com/yuriw-2022-09-20_17:39:55-rados-wip-yuri5-testing-2022-09-19-1007-pacific-distro-default-smithi/7039204/ and it says "rados/cephadm/dashboard/{0-distro/ignorelist_health task/test_e2e}". Do you know where it's getting this distor from? The only thing I see listed in that 0-distro dir is an 8.stream one thathsould be okay https://github.com/ceph/ceph/tree/pacific/qa/suites/orch/cephadm/dashboard/0-distro. The "fix" for this in the orch/cephadm/workunits tests was to just specify distros so we didn't take the default ubuntu jammy that was missing packages. Not sure how to fix that specific test given I'm not sure were it's pulling it's distro from.

Actions #12

Updated by Laura Flores over 1 year ago

@Adam DC949 in the rados suite, this test seems to have additional distros: https://github.com/ceph/ceph/tree/pacific/qa/suites/rados/dashboard

If the orch suite only has support for centos 8, perhaps the rados support for additional distros needs to be removed?

I'm also noticing that the os type and os version are left blank, i.e. in the job below:
http://pulpito.front.sepia.ceph.com/yuriw-2022-11-30_23:13:27-rados-wip-yuri2-testing-2022-11-30-0724-pacific-distro-default-smithi/7099407/

Actions #13

Updated by Laura Flores 12 months ago

/a/yuriw-2023-04-25_14:15:40-rados-pacific-release-distro-default-smithi/7251328

Actions #14

Updated by Laura Flores 12 months ago

/a/yuriw-2023-04-26_01:16:19-rados-wip-yuri11-testing-2023-04-25-1605-pacific-distro-default-smithi/7254087

Actions #15

Updated by Laura Flores 12 months ago

  • Has duplicate Bug #59193: "Failed to fetch package version from https://shaman.ceph.com/api/search ..." added
Actions #16

Updated by Laura Flores 12 months ago

  • Status changed from New to Pending Backport
Actions #18

Updated by Laura Flores 12 months ago

  • Status changed from Pending Backport to Resolved
Actions #19

Updated by Laura Flores 10 months ago

  • Has duplicate deleted (Bug #59193: "Failed to fetch package version from https://shaman.ceph.com/api/search ...")
Actions #20

Updated by Laura Flores 5 months ago

/a/yuriw-2023-11-16_22:27:54-rados-wip-yuri4-testing-2023-11-13-0820-pacific-distro-default-smithi/7461242

Actions #21

Updated by Laura Flores 2 months ago

/a//lflores-2024-02-15_17:32:20-rados-wip-yuri10-testing-2024-02-08-0854-pacific-distro-default-smithi/7561659

Actions

Also available in: Atom PDF