Project

General

Profile

Documentation #55530

teuthology-suite -k option doesn't always override kernel

Added by Jeff Layton 7 months ago. Updated 6 months ago.

Status:
Resolved
Priority:
Normal
Category:
-
Target version:
% Done:

0%

Tags:
Backport:
Reviewed:
Affected Versions:
Pull request ID:

Description

teuthology-suite doesn't currently respect the -k option, which is supposed to override the kernel used in testing. To reproduce:

teuthology-suite  --machine-type smithi -p 50 --suite fs:thrash -k wip-fscrypt --force-priority   -l 16

The resulting kernels used in the test will end up being a mix of the one specified via -k and distro kernels. Ilya mentioned this in a private email thread:

I think this is because the fs suite supplies overrides for the kernel
task.  I never liked that idea precisely because it makes any debugging
harder than it should be.  OTOH when everything works it results in all
kernels being covered by a single test run.

I don't really care what happens when -k isn't specified to teuthology-suite, but when it is specified it should be used universally.

History

#1 Updated by Venky Shankar 6 months ago

  • Tracker changed from Bug to Feature
  • Assignee set to Patrick Donnelly

#2 Updated by Patrick Donnelly 6 months ago

  • Tracker changed from Feature to Documentation
  • Project changed from teuthology to Ceph
  • Status changed from New to In Progress
  • Target version set to v18.0.0

#3 Updated by Patrick Donnelly 6 months ago

  • Status changed from In Progress to Fix Under Review
  • Pull request ID set to 46516

#4 Updated by Patrick Donnelly 6 months ago

  • Status changed from Fix Under Review to Resolved

Also available in: Atom PDF