Project

General

Profile

Bug #5412

doc bug: incorrect reference to monitor quorum requirements

Added by Greg Farnum about 6 years ago. Updated almost 6 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
06/20/2013
Due date:
% Done:

0%

Source:
other
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

http://ceph.com/docs/master/rados/deployment/ceph-deploy-mon/

You can establish a monitor quorum with only one monitor; however, you can not determine a majority with two monitors. A majority of monitors must be counted as such: 1:1, 2:3, 3:4, 3:5, 4:6, etc.

You can establish a quorum with two monitors, it's just not good deployment practices because it doesn't provide any extra durability over one monitor. There's enough confusion on this topic in the community that we need to be very careful about our own docs (should probably audit for similar references or confusing statements).

Associated revisions

Revision 576dce03 (diff)
Added by John Wilkins almost 6 years ago

doc: Clarified quorum requirements.

fixes: #5412

Signed-off-by: John Wilkins <>

History

Also available in: Atom PDF