Project

General

Profile

Bug #50435

arm64 build broken: built binaries fail on: load: jerasure load: lrc load dlopen

Added by Andreas Elvers 27 days ago. Updated 3 days ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
build
Target version:
% Done:

0%

Source:
Community (user)
Tags:
arm64
Backport:
Regression:
No
Severity:
2 - major
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

Since ceph 15.2.8 on ARM64 the osd binary (most probably other binaries as well) fails to start with the error message:

load: jerasure load: lrc load dlopen(/usr/lib/ceph/erasure-code/libec_isa.so): /usr/lib/ceph/erasure-code/libec_isa.so: cannot restore segment prot after reloc: Operation not permitted

According to https://bugs.launchpad.net/ubuntu/+source/ceph/+bug/1917414 this is due to a problem with isa-l library that seems to be incorporated into the binaries. But this is beyond me.

Release: Ubuntu Bionic / Ceph 15.2.8 through 15.2.11
Architecture: ARM64

Expected behaviour:
OSD should startup
Actual behaviour:
OSD startup fails

Startup log of osd:

2021-04-20T09:07:10.713+0000 7f89c74010 0 ceph version 15.2.11 (e3523634d9c2227df9af89a4eac33d16738c49cb) octopus (stable), process ceph-osd, pid 1761
2021-04-20T09:07:10.713+0000 7f89c74010 0 pidfile_write: ignore empty --pid-file
2021-04-20T09:07:10.717+0000 7f89c74010 1 bdev create path /var/lib/ceph/osd/ceph-3/block type kernel
2021-04-20T09:07:10.717+0000 7f89c74010 1 bdev(0x55b6512000 /var/lib/ceph/osd/ceph-3/block) open path /var/lib/ceph/osd/ceph-3/block
2021-04-20T09:07:10.717+0000 7f89c74010 0 bdev(0x55b6512000 /var/lib/ceph/osd/ceph-3/block) ioctl(F_SET_FILE_RW_HINT) on /var/lib/ceph/osd/ceph-3/block failed: (22) Invalid argument
2021-04-20T09:07:10.717+0000 7f89c74010 1 bdev(0x55b6512000 /var/lib/ceph/osd/ceph-3/block) open size 14000486088704 (0xcbbbe000000, 13 TiB) block_size 4096 (4 KiB) rotational discard not supported
2021-04-20T09:07:10.721+0000 7f89c74010 1 bluestore(/var/lib/ceph/osd/ceph-3) _set_cache_sizes cache_size 1073741824 meta 0.4 kv 0.4 data 0.2
2021-04-20T09:07:10.721+0000 7f89c74010 1 bdev create path /var/lib/ceph/osd/ceph-3/block type kernel
2021-04-20T09:07:10.721+0000 7f89c74010 1 bdev(0x55b6512380 /var/lib/ceph/osd/ceph-3/block) open path /var/lib/ceph/osd/ceph-3/block
2021-04-20T09:07:10.721+0000 7f89c74010 0 bdev(0x55b6512380 /var/lib/ceph/osd/ceph-3/block) ioctl(F_SET_FILE_RW_HINT) on /var/lib/ceph/osd/ceph-3/block failed: (22) Invalid argument
2021-04-20T09:07:10.721+0000 7f89c74010 1 bdev(0x55b6512380 /var/lib/ceph/osd/ceph-3/block) open size 14000486088704 (0xcbbbe000000, 13 TiB) block_size 4096 (4 KiB) rotational discard not supported
2021-04-20T09:07:10.721+0000 7f89c74010 1 bluefs add_block_device bdev 1 path /var/lib/ceph/osd/ceph-3/block size 13 TiB
2021-04-20T09:07:10.721+0000 7f89c74010 1 bdev(0x55b6512380 /var/lib/ceph/osd/ceph-3/block) close
2021-04-20T09:07:11.001+0000 7f89c74010 1 bdev(0x55b6512000 /var/lib/ceph/osd/ceph-3/block) close
2021-04-20T09:07:11.249+0000 7f89c74010 0 starting osd.3 osd_data /var/lib/ceph/osd/ceph-3 /var/lib/ceph/osd/ceph-3/journal
2021-04-20T09:07:11.297+0000 7f89c74010 -1 load: jerasure load: lrc load dlopen(/usr/lib/ceph/erasure-code/libec_isa.so): /usr/lib/ceph/erasure-code/libec_isa.so: cannot restore segment prot after reloc: Operation not permitted

History

#1 Updated by Loïc Dachary 26 days ago

  • Target version changed from v15.2.11 to v15.2.12

#2 Updated by Greg Farnum 10 days ago

  • Status changed from New to Duplicate

It looks like this is now fixed in the Ubuntu repos but it's unclear to me if the upstream packages we provide suffer from the same issue or not.

But from the launchpad issue it looks to me like this is a duplicate of https://tracker.ceph.com/issues/48681

#3 Updated by Andreas Elvers 10 days ago

The error persists in the bionic versions on http://download.ceph.com/debian-octopus. The ubuntu packages are fixed to a certain ubuntu version where's the upstream download.ceph.com allow to install octopus or pacific on bionic. this is not possible with the ubuntu repository.

I don't see a duplicated issue here.

#4 Updated by Loïc Dachary 3 days ago

  • Target version changed from v15.2.12 to v15.2.13

Also available in: Atom PDF