Project

General

Profile

Bug #49205

orchestrator/01-hosts.e2e-spec.ts failed in test_dashboard_e2e.sh

Added by Kefu Chai 18 days ago. Updated 8 days ago.

Status:
Pending Backport
Priority:
High
Assignee:
Category:
-
Target version:
% Done:

0%

Source:
Tags:
Backport:
pacific,octopus
Regression:
Yes
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:
Tags:

Description

2021-02-08T02:41:42.641 INFO:tasks.workunit.client.0.smithi068.stderr:+ cypress_run orchestrator/01-hosts.e2e-spec.ts
2021-02-08T02:41:42.641 INFO:tasks.workunit.client.0.smithi068.stderr:+ local specs=orchestrator/01-hosts.e2e-spec.ts
2021-02-08T02:41:42.641 INFO:tasks.workunit.client.0.smithi068.stderr:+ local timeout=
2021-02-08T02:41:42.641 INFO:tasks.workunit.client.0.smithi068.stderr:+ local 'override_config=ignoreTestFiles=*.po.ts,retries=0,testFiles=orchestrator/01-hosts.e2e-spec.ts'
2021-02-08T02:41:42.641 INFO:tasks.workunit.client.0.smithi068.stderr:+ '[' x '!=' x ']'
2021-02-08T02:41:42.641 INFO:tasks.workunit.client.0.smithi068.stderr:+ npx cypress run --browser chrome --headless --config 'ignoreTestFiles=*.po.ts,retries=0,testFiles=orchestrator/01-hosts.e2e-spec.ts'
2021-02-08T02:41:46.338 INFO:tasks.workunit.client.0.smithi068.stderr:Couldn't determine Mocha version
2021-02-08T02:41:46.360 INFO:tasks.workunit.client.0.smithi068.stdout:
2021-02-08T02:41:46.396 INFO:tasks.workunit.client.0.smithi068.stderr:tput: No value for $TERM and no -T specified
2021-02-08T02:41:46.396 INFO:tasks.workunit.client.0.smithi068.stdout:================================================================================
2021-02-08T02:41:46.396 INFO:tasks.workunit.client.0.smithi068.stdout:
2021-02-08T02:41:46.396 INFO:tasks.workunit.client.0.smithi068.stdout:  (Run Starting)
2021-02-08T02:41:46.396 INFO:tasks.workunit.client.0.smithi068.stdout:
2021-02-08T02:41:46.402 INFO:tasks.workunit.client.0.smithi068.stdout:  ┌────────────────────────────────────────────────────────────────────────────────────────────────┐
2021-02-08T02:41:46.402 INFO:tasks.workunit.client.0.smithi068.stdout:  │ Cypress:    5.3.0                                                                              │
2021-02-08T02:41:46.402 INFO:tasks.workunit.client.0.smithi068.stdout:  │ Browser:    Chrome 88 (headless)                                                               │
2021-02-08T02:41:46.402 INFO:tasks.workunit.client.0.smithi068.stdout:  │ Specs:      1 found (orchestrator/01-hosts.e2e-spec.ts)                                        │
2021-02-08T02:41:46.403 INFO:tasks.workunit.client.0.smithi068.stdout:  └────────────────────────────────────────────────────────────────────────────────────────────────┘
2021-02-08T02:41:46.403 INFO:tasks.workunit.client.0.smithi068.stdout:
2021-02-08T02:41:46.403 INFO:tasks.workunit.client.0.smithi068.stdout:
2021-02-08T02:41:46.404 INFO:tasks.workunit.client.0.smithi068.stdout:────────────────────────────────────────────────────────────────────────────────────────────────────
2021-02-08T02:41:46.404 INFO:tasks.workunit.client.0.smithi068.stdout:
2021-02-08T02:41:46.404 INFO:tasks.workunit.client.0.smithi068.stdout:  Running:  orchestrator/01-hosts.e2e-spec.ts                                               (1 of 1)
2021-02-08T02:41:49.754 INFO:tasks.workunit.client.0.smithi068.stderr:Couldn't determine Mocha version
2021-02-08T02:41:49.760 INFO:tasks.workunit.client.0.smithi068.stdout:
2021-02-08T02:41:49.761 INFO:tasks.workunit.client.0.smithi068.stdout:
2021-02-08T02:41:49.769 INFO:tasks.workunit.client.0.smithi068.stdout:  Hosts page
2021-02-08T02:41:49.769 INFO:tasks.workunit.client.0.smithi068.stdout:    when Orchestrator is available
2021-02-08T02:41:51.289 INFO:tasks.workunit.client.0.smithi068.stdout:      ✓ should not add an exsiting host (1501ms)
2021-02-08T02:41:58.769 INFO:tasks.workunit.client.0.smithi068.stdout:      ✓ should delete a host and add it back (7399ms)
2021-02-08T02:41:59.675 INFO:tasks.workunit.client.0.smithi068.stdout:      ✓ should display inventory (879ms)
2021-02-08T02:42:00.608 INFO:tasks.workunit.client.0.smithi068.stdout:      ✓ should display daemons (904ms)
2021-02-08T02:44:02.977 INFO:tasks.workunit.client.0.smithi068.stdout:      1) should edit host labels
2021-02-08T02:44:03.141 INFO:tasks.workunit.client.0.smithi068.stdout:
2021-02-08T02:44:03.142 INFO:tasks.workunit.client.0.smithi068.stdout:
2021-02-08T02:44:03.142 INFO:tasks.workunit.client.0.smithi068.stdout:  4 passing (2m)
2021-02-08T02:44:03.142 INFO:tasks.workunit.client.0.smithi068.stdout:  1 failing
2021-02-08T02:44:03.142 INFO:tasks.workunit.client.0.smithi068.stdout:
2021-02-08T02:44:03.142 INFO:tasks.workunit.client.0.smithi068.stdout:  1) Hosts page
2021-02-08T02:44:03.142 INFO:tasks.workunit.client.0.smithi068.stdout:       when Orchestrator is available
2021-02-08T02:44:03.142 INFO:tasks.workunit.client.0.smithi068.stdout:         should edit host labels:
2021-02-08T02:44:03.142 INFO:tasks.workunit.client.0.smithi068.stdout:     AssertionError: Timed out retrying: expected [ ' bar   foo ' ] to include 'foo'
2021-02-08T02:44:03.143 INFO:tasks.workunit.client.0.smithi068.stdout:      at Context.eval (https://smithi068:8443/__cypress/tests?p=cypress/integration/orchestrator/01-hosts.e2e-spec.ts:201:42)

in /log/ed1517d4-69b5-11eb-8fde-001a4aab830c/ceph-mgr.a.log

2021-02-08T02:42:00.913+0000 7fdfa5a54700  0 [dashboard ERROR exception] Internal Server Error
Traceback (most recent call last):
  File "/usr/share/ceph/mgr/dashboard/services/exception.py", line 46, in dashboard_exception_handler
    return handler(*args, **kwargs)
  File "/lib/python3.6/site-packages/cherrypy/_cpdispatch.py", line 54, in __call__
    return self.callable(*self.args, **self.kwargs)
  File "/usr/share/ceph/mgr/dashboard/controllers/home.py", line 135, in __call__
    return serve_file(full_path)
  File "/lib/python3.6/site-packages/cherrypy/lib/static.py", line 77, in serve_file
    cptools.validate_since()
  File "/lib/python3.6/site-packages/cherrypy/lib/cptools.py", line 116, in validate_since
    raise cherrypy.HTTPRedirect([], 304)
cherrypy._cperror.HTTPRedirect: ([], 304)

the e2e test was still green in

- https://pulpito.ceph.com/yuriw-2021-02-03_20:10:29-rados:cephadm-wip-yuri6-testing-2021-02-03-0803-distro-basic-smithi/5854552/. tested sha1: b70a63a91759ac9ae5c696580d78ed2543409e9b
- https://pulpito.ceph.com/kchai-2021-02-07_16:22:52-rados-master-distro-basic-smithi/5865046/, tested sha1: 4308142b0929dc07a17f511ca9000197e53309da

/a/kchai-2021-02-08_02:14:21-rados-wip-kefu2-testing-2021-02-08-0023-distro-basic-smithi/5865428


Related issues

Duplicated by Orchestrator - Bug #49350: cephadm/test_dashboard_e2e.sh: AssertionError: Timed out retrying: expected [ ' bar   foo ' ] to include 'foo' Duplicate
Follows mgr - Cleanup #49105: mgr/dashboard: Add a badge to the Label column of the Host List Pending Backport
Copied to mgr - Backport #49337: octopus: orchestrator/01-hosts.e2e-spec.ts failed in test_dashboard_e2e.sh New
Copied to mgr - Backport #49338: pacific: orchestrator/01-hosts.e2e-spec.ts failed in test_dashboard_e2e.sh New

History

#1 Updated by Kefu Chai 18 days ago

  • Regression changed from No to Yes

#2 Updated by Sebastian Wagner 17 days ago

the mgr-log file looks good:

2021-02-07T16:51:43.971+0000 7fce822f1700  1 -- 172.21.15.17:0/443283831 <== mon.0 v2:172.21.15.17:3300/0 1059 ==== mon_command_ack([{prefix=config-key set, key=mgr/cephadm/inventory}]=0 set mgr/cephadm/inventory v0)=0 set mgr/cephadm/inventory v0) v1 ==== 342+0+0 (secure 0 0 0) 0x55b3c70bc1a0 con 0x55b3c6b96400
2021-02-07T16:51:43.971+0000 7fce3b45e700  0 [dashboard DEBUG notification_queue] processing queue: 1
2021-02-07T16:51:43.971+0000 7fce5f1e8700  0 [restful DEBUG root] Unhandled notification type 'service_map'
2021-02-07T16:51:43.971+0000 7fce3c460700  0 [cephadm INFO root] Added label foo to host smithi120
2021-02-07T16:51:43.971+0000 7fce3c460700  0 log_channel(cephadm) log [INF] : Added label foo to host smithi120
2021-02-07T16:51:43.971+0000 7fce3c460700  0 [cephadm DEBUG orchestrator._interface] finalized cephadm.module.CephadmCompletion(_s=3, val='Added label foo to host smithi120', _on_c=<function trivial_completion.<locals>.wrapper.<locals>.<lambda> at 0x7fce5cae0e18>, id=140524296273592, name=<lambda>, pr=NA, _next=None)
2021-02-07T16:51:43.971+0000 7fce3c460700 20 mgr dispatch_remote Success calling 'process'
2021-02-07T16:51:43.971+0000 7fce3c460700  0 [dashboard INFO root] Operations pending: 0
2021-02-07T16:51:43.971+0000 7fce3c460700 20 mgr dispatch_remote Calling orchestrator._select_orchestrator...
2021-02-07T16:51:43.971+0000 7fce3c460700 20 mgr get_config  key: mgr/orchestrator/orchestrator
2021-02-07T16:51:43.971+0000 7fce3c460700 10 mgr get_typed_config get_typed_config orchestrator found
2021-02-07T16:51:43.971+0000 7fce3c460700 20 mgr dispatch_remote Success calling '_select_orchestrator'
2021-02-07T16:51:43.971+0000 7fce3c460700  0 [dashboard DEBUG root] _oremote dashboard -> cephadm.add_host_label(*('smithi120', 'bar'), **{})
2021-02-07T16:51:43.971+0000 7fce3c460700 20 mgr dispatch_remote Calling cephadm.add_host_label...
2021-02-07T16:51:43.971+0000 7fce3c460700 20 mgr dispatch_remote Success calling 'add_host_label'
2021-02-07T16:51:43.971+0000 7fce3c460700 20 mgr dispatch_remote Calling orchestrator._select_orchestrator...
2021-02-07T16:51:43.971+0000 7fce3c460700 20 mgr get_config  key: mgr/orchestrator/orchestrator
2021-02-07T16:51:43.971+0000 7fce3c460700 10 mgr get_typed_config get_typed_config orchestrator found
2021-02-07T16:51:43.971+0000 7fce3c460700 20 mgr dispatch_remote Success calling '_select_orchestrator'
2021-02-07T16:51:43.972+0000 7fce3c460700  0 [dashboard DEBUG root] _oremote dashboard -> cephadm.process(*([cephadm.module.CephadmCompletion(_s=1, val=NA, _on_c=<function trivial_completion.<locals>.wrapper.<locals>.<lambda> at 0x7fce5cae0ea0>, id=140524296270344, name=<lambda>, pr=NA, _next=None)],), **{})
2021-02-07T16:51:43.972+0000 7fce3c460700 20 mgr dispatch_remote Calling cephadm.process...
2021-02-07T16:51:43.972+0000 7fce3c460700  0 [cephadm DEBUG root] process: completions=<CephadmCompletion>[
       <lambda>(...),
]
2021-02-07T16:51:43.972+0000 7fce3c460700  1 -- 172.21.15.17:0/443283831 --> [v2:172.21.15.17:3300/0,v1:172.21.15.17:6789/0] -- mon_command([{prefix=config-key set, key=mgr/cephadm/inventory}] v 0) v1 -- 0x55b3c78cb800 con 0x55b3c6b96400
2021-02-07T16:51:43.976+0000 7fce822f1700  1 -- 172.21.15.17:0/443283831 <== mon.0 v2:172.21.15.17:3300/0 1060 ==== service_map(e5 0 svc) v1 ==== 22+0+0 (secure 0 0 0) 0x55b3c78cb800 con 0x55b3c6b96400
2021-02-07T16:51:43.976+0000 7fce822f1700 10 mgr ms_dispatch2 active service_map(e5 0 svc) v1
2021-02-07T16:51:43.976+0000 7fce822f1700 10 mgr ms_dispatch2 service_map(e5 0 svc) v1
2021-02-07T16:51:43.976+0000 7fce822f1700 10 mgr handle_service_map e5
2021-02-07T16:51:43.976+0000 7fce822f1700 10 mgr.server operator() got updated map e5
2021-02-07T16:51:43.976+0000 7fce822f1700 10 mgr notify_all notify_all: notify_all service_map
2021-02-07T16:51:43.976+0000 7fce822f1700 15 mgr notify_all queuing notify to balancer
2021-02-07T16:51:43.976+0000 7fce822f1700 15 mgr notify_all queuing notify to cephadm
2021-02-07T16:51:43.976+0000 7fce822f1700 15 mgr notify_all queuing notify to crash
2021-02-07T16:51:43.976+0000 7fce822f1700 15 mgr notify_all queuing notify to dashboard
2021-02-07T16:51:43.976+0000 7fce822f1700 15 mgr notify_all queuing notify to devicehealth
2021-02-07T16:51:43.976+0000 7fce822f1700 15 mgr notify_all queuing notify to iostat
2021-02-07T16:51:43.976+0000 7fce822f1700 15 mgr notify_all queuing notify to orchestrator
2021-02-07T16:51:43.976+0000 7fce822f1700 15 mgr notify_all queuing notify to pg_autoscaler
2021-02-07T16:51:43.976+0000 7fce822f1700 15 mgr notify_all queuing notify to progress
2021-02-07T16:51:43.976+0000 7fce822f1700 15 mgr notify_all queuing notify to rbd_support
2021-02-07T16:51:43.976+0000 7fce822f1700 15 mgr notify_all queuing notify to restful
2021-02-07T16:51:43.976+0000 7fce822f1700 15 mgr notify_all queuing notify to status
2021-02-07T16:51:43.976+0000 7fce822f1700 15 mgr notify_all queuing notify to telemetry
2021-02-07T16:51:43.976+0000 7fce822f1700 15 mgr notify_all queuing notify to volumes
2021-02-07T16:51:43.976+0000 7fce3b45e700  0 [dashboard DEBUG notification_queue] processing queue: 1
2021-02-07T16:51:43.976+0000 7fce822f1700  1 -- 172.21.15.17:0/443283831 <== mon.0 v2:172.21.15.17:3300/0 1061 ==== mon_command_ack([{prefix=config-key set, key=mgr/cephadm/inventory}]=0 set mgr/cephadm/inventory v0)=0 set mgr/cephadm/inventory v0) v1 ==== 351+0+0 (secure 0 0 0) 0x55b3c7675d40 con 0x55b3c6b96400
2021-02-07T16:51:43.976+0000 7fce3c460700  0 [cephadm INFO root] Added label bar to host smithi120
2021-02-07T16:51:43.976+0000 7fce3c460700  0 log_channel(cephadm) log [INF] : Added label bar to host smithi120
2021-02-07T16:51:43.976+0000 7fce5f1e8700  0 [restful DEBUG root] Unhandled notification type 'service_map'
2021-02-07T16:51:43.976+0000 7fce3c460700  0 [cephadm DEBUG orchestrator._interface] finalized cephadm.module.CephadmCompletion(_s=3, val='Added label bar to host smithi120', _on_c=<function trivial_completion.<locals>.wrapper.<locals>.<lambda> at 0x7fce5cae0ea0>, id=140524296270344, name=<lambda>, pr=NA, _next=None)
2021-02-07T16:51:43.976+0000 7fce3c460700 20 mgr dispatch_remote Success calling 'process'

#3 Updated by Kefu Chai 17 days ago

was trying to bisect this issue: https://pulpito.ceph.com/?suite=rados%3Acephadm%3Adashboard

per Juan Miguel Olmo Martínez, it's related to https://bugzilla.redhat.com/show_bug.cgi?id=1920461. but due to missing dependencies, the updated python-cherrypy was down voted on https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2021-4b4520f49d.

#4 Updated by Kefu Chai 17 days ago

  • Tags set to e2e

#5 Updated by Kefu Chai 17 days ago

  • Tags changed from e2e to e2e cephadm

#6 Updated by Kefu Chai 17 days ago

  • Tags set to e2e, cephadm
  • Tags deleted (e2e cephadm)

#7 Updated by Nizamudeen A 17 days ago

  • Status changed from New to Fix Under Review
  • Assignee set to Nizamudeen A
  • Pull request ID set to 39363

Raised a PR. e2e broke after making this changes in dashboard: https://github.com/ceph/ceph/pull/39229

#8 Updated by Kefu Chai 8 days ago

  • Status changed from Fix Under Review to Resolved

#9 Updated by Ernesto Puerta 8 days ago

  • Status changed from Resolved to Pending Backport
  • Backport set to pacific,octopus

#10 Updated by Ernesto Puerta 8 days ago

  • Follows Cleanup #49105: mgr/dashboard: Add a badge to the Label column of the Host List added

#11 Updated by Backport Bot 8 days ago

  • Copied to Backport #49337: octopus: orchestrator/01-hosts.e2e-spec.ts failed in test_dashboard_e2e.sh added

#12 Updated by Backport Bot 8 days ago

  • Copied to Backport #49338: pacific: orchestrator/01-hosts.e2e-spec.ts failed in test_dashboard_e2e.sh added

#13 Updated by Sebastian Wagner 7 days ago

  • Duplicated by Bug #49350: cephadm/test_dashboard_e2e.sh: AssertionError: Timed out retrying: expected [ ' bar   foo ' ] to include 'foo' added

Also available in: Atom PDF