Project

General

Profile

Actions

Bug #48921

closed

teuthology vault unzip fails on centos-8

Added by Marcus Watts about 3 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
pacific
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
teuthology
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

While trying to test vault transit encoding on a toy centos-8 instance, I ran into another problem: unzipping the just downloaded zipfile of vault failed. The command that failed was "python -m zipfile -e /home/ubuntu/cephtest/vault.zip /home/ubuntu/cephtest/vault" and the reason that failed is that "/usr/bin/python" did not exist. This is an expected condition on centos-8, in fact there's a man page on just this: "man unversioned-python".

It's possible to fix that by using "update-alternatives", but I don't think we want to make that a requirement of all ceph installs. Using "python2 -m" "python3 -m" or "unzip" is also possible, but might not exist in all cases. The teuthology environment does not collect and save good information on the deployment host(s), so there's no really elegant way to finesse this.


Related issues 1 (0 open1 closed)

Copied to rgw - Backport #49042: pacific: teuthology vault unzip fails on centos-8ResolvedCasey BodleyActions
Actions #1

Updated by Marcus Watts about 3 years ago

I have a possible fix for this in https://github.com/ceph/ceph/pull/38605

My fix tries for "unzip", then "python3", then "python" in that order. I suspect most people would just install and expect "unzip" to work, (it works for me!), "python3" is probably required by vault anyways, and "python" is what the original code used, so it must be correct somewhere.

Actions #2

Updated by Marcus Watts about 3 years ago

Actions #3

Updated by Casey Bodley about 3 years ago

  • Status changed from New to Pending Backport
  • Backport set to pacific
  • Pull request ID set to 39008
Actions #4

Updated by Backport Bot about 3 years ago

  • Copied to Backport #49042: pacific: teuthology vault unzip fails on centos-8 added
Actions #5

Updated by Nathan Cutler about 3 years ago

  • Status changed from Pending Backport to Resolved

While running with --resolve-parent, the script "backport-create-issue" noticed that all backports of this issue are in status "Resolved" or "Rejected".

Actions

Also available in: Atom PDF