Project

General

Profile

Bug #48406

cephadm/test_dashboard_e2e.sh: error when testing orchestrator/04-osds.e2e-spec.ts

Added by Kiefer Chang about 2 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Testing & QA
Target version:
-
% Done:

0%

Source:
Development
Tags:
Backport:
Regression:
Yes
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

https://pulpito.ceph.com/teuthology-2020-11-30_07:01:02-rados-master-distro-basic-smithi/5668852/

2020-11-30T12:20:26.096 INFO:tasks.workunit.client.0.smithi065.stdout:  OSDs page
2020-11-30T12:20:26.097 INFO:tasks.workunit.client.0.smithi065.stdout:    when Orchestrator is available
2020-11-30T12:26:10.476 INFO:tasks.workunit.client.0.smithi065.stdout:      1) should create and delete OSDs
2020-11-30T12:26:10.931 INFO:tasks.workunit.client.0.smithi065.stdout:
2020-11-30T12:26:10.932 INFO:tasks.workunit.client.0.smithi065.stdout:
2020-11-30T12:26:10.933 INFO:tasks.workunit.client.0.smithi065.stdout:  0 passing (6m)
2020-11-30T12:26:10.933 INFO:tasks.workunit.client.0.smithi065.stdout:  1 failing
2020-11-30T12:26:10.933 INFO:tasks.workunit.client.0.smithi065.stdout:
2020-11-30T12:26:10.934 INFO:tasks.workunit.client.0.smithi065.stdout:  1) OSDs page
2020-11-30T12:26:10.934 INFO:tasks.workunit.client.0.smithi065.stdout:       when Orchestrator is available
2020-11-30T12:26:10.934 INFO:tasks.workunit.client.0.smithi065.stdout:         should create and delete OSDs:
2020-11-30T12:26:10.934 INFO:tasks.workunit.client.0.smithi065.stdout:     AssertionError: Timed out retrying: Expected to find element: `cd-modal label[for="preserve"]`, but never found it
.
2020-11-30T12:26:10.935 INFO:tasks.workunit.client.0.smithi065.stdout:      at OSDsPageHelper.deleteByIDs (https://smithi065:8443/__cypress/tests?p=cypress/integration/orchestrator/04-osds.
e2e-spec.ts:161:16)
2020-11-30T12:26:10.935 INFO:tasks.workunit.client.0.smithi065.stdout:      at OSDsPageHelper.descriptor.value (https://smithi065:8443/__cypress/tests?p=cypress/integration/orchestrator/04-
osds.e2e-spec.ts:275:20)
2020-11-30T12:26:10.935 INFO:tasks.workunit.client.0.smithi065.stdout:      at Context.eval (https://smithi065:8443/__cypress/tests?p=cypress/integration/orchestrator/04-osds.e2e-spec.ts:23
9:26)

The error is caused by this change: https://github.com/ceph/ceph/pull/35039
The OSD column now has a status (`deleting...`), which makes the array comparison fail.

During investigating this problem, I found the test fails earlier with master code:

  OSDs page
    when Orchestrator is available
      1) should create and delete OSDs

  0 passing (5s)
  1 failing

  1) OSDs page
       when Orchestrator is available
         should create and delete OSDs:
     TypeError: The following error originated from your application code, not from Cypress.

  > Cannot set property 'loading' of undefined

When Cypress detects uncaught errors originating from your application it will automatically fail the current test.

This behavior is configurable, and you can choose to turn this off by listening to the `uncaught:exception` event.

https://on.cypress.io/uncaught-exception-from-application

This was caused by the changes in https://github.com/ceph/ceph/pull/37994
We really need a method to run the orchestrator e2e test on every PR.


Related issues

Related to Dashboard - Bug #48421: mgr/dashboard: Displaying the OSD preview modal raises an exception. Resolved

History

#1 Updated by Kiefer Chang about 2 years ago

  • Description updated (diff)

#2 Updated by Kiefer Chang about 2 years ago

  • Related to Bug #48421: mgr/dashboard: Displaying the OSD preview modal raises an exception. added

#3 Updated by Kiefer Chang about 2 years ago

  • Status changed from In Progress to Fix Under Review
  • Pull request ID set to 38384

#4 Updated by Kefu Chai about 2 years ago

  • Status changed from Fix Under Review to Resolved

#5 Updated by Ernesto Puerta almost 2 years ago

  • Project changed from mgr to Dashboard
  • Category changed from 151 to Testing & QA

Also available in: Atom PDF