Project

General

Profile

Bug #45993

rgw/test_rgw_orphan_list.sh fails due to NoSuchBucket

Added by Kefu Chai about 2 months ago. Updated 25 days ago.

Status:
Duplicate
Priority:
Normal
Assignee:
Target version:
-
% Done:

0%

Source:
Tags:
orphans
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

2020-06-14T13:52:50.565 INFO:tasks.workunit.client.0.smithi026.stderr:DEBUG: Canonical Request:
2020-06-14T13:52:50.565 INFO:tasks.workunit.client.0.smithi026.stderr:PUT
2020-06-14T13:52:50.565 INFO:tasks.workunit.client.0.smithi026.stderr:/multipart-bkt/
2020-06-14T13:52:50.566 INFO:tasks.workunit.client.0.smithi026.stderr:
2020-06-14T13:52:50.566 INFO:tasks.workunit.client.0.smithi026.stderr:host:smithi026
2020-06-14T13:52:50.566 INFO:tasks.workunit.client.0.smithi026.stderr:x-amz-content-sha256:e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855
2020-06-14T13:52:50.566 INFO:tasks.workunit.client.0.smithi026.stderr:x-amz-date:20200614T135250Z
2020-06-14T13:52:50.566 INFO:tasks.workunit.client.0.smithi026.stderr:
2020-06-14T13:52:50.566 INFO:tasks.workunit.client.0.smithi026.stderr:host;x-amz-content-sha256;x-amz-date
2020-06-14T13:52:50.566 INFO:tasks.workunit.client.0.smithi026.stderr:e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855
2020-06-14T13:52:50.566 INFO:tasks.workunit.client.0.smithi026.stderr:----------------------
2020-06-14T13:52:50.567 INFO:tasks.workunit.client.0.smithi026.stderr:DEBUG: signature-v4 headers: {'x-amz-date': '20200614T135250Z', 'Authorization': 'AWS4-HMAC-SHA256 Credential=0555b35654ad1656d804/202
00614/us-east-1/s3/aws4_request,SignedHeaders=host;x-amz-content-sha256;x-amz-date,Signature=a1c634600f25812268913be91709a2f1c91b48eea56c1bffcf1917f6a31430e6', 'x-amz-content-sha256': 'e3b0c44298fc1c149af
bf4c8996fb92427ae41e4649b934ca495991b7852b855'}
2020-06-14T13:52:50.567 INFO:tasks.workunit.client.0.smithi026.stderr:DEBUG: Processing request, please wait...
2020-06-14T13:52:50.567 INFO:tasks.workunit.client.0.smithi026.stderr:DEBUG: get_hostname(multipart-bkt): smithi026
2020-06-14T13:52:50.567 INFO:tasks.workunit.client.0.smithi026.stderr:DEBUG: ConnMan.get(): creating new connection: http://smithi026
2020-06-14T13:52:50.567 INFO:tasks.workunit.client.0.smithi026.stderr:DEBUG: non-proxied HTTPConnection(smithi026, None)
2020-06-14T13:52:50.569 INFO:tasks.workunit.client.0.smithi026.stderr:DEBUG: format_uri(): /multipart-bkt/
2020-06-14T13:52:50.569 INFO:tasks.workunit.client.0.smithi026.stderr:DEBUG: Sending request method_string='PUT', uri='/multipart-bkt/', headers={'x-amz-date': '20200614T135250Z', 'Authorization': 'AWS4-H
MAC-SHA256 Credential=0555b35654ad1656d804/20200614/us-east-1/s3/aws4_request,SignedHeaders=host;x-amz-content-sha256;x-amz-date,Signature=a1c634600f25812268913be91709a2f1c91b48eea56c1bffcf1917f6a31430e6'
, 'x-amz-content-sha256': 'e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855'}, body=(0 bytes)
2020-06-14T13:52:50.569 INFO:tasks.workunit.client.0.smithi026.stderr:DEBUG: ConnMan.put(): connection put back to pool (http://smithi026#1)
2020-06-14T13:52:50.570 INFO:tasks.workunit.client.0.smithi026.stderr:DEBUG: Response:
2020-06-14T13:52:50.570 INFO:tasks.workunit.client.0.smithi026.stderr:{'data': b'<?xml version="1.0" encoding="UTF-8"?><Error><Code>NoSuchBucket</Cod'
2020-06-14T13:52:50.570 INFO:tasks.workunit.client.0.smithi026.stderr:         b'e><BucketName>smithi026</BucketName><RequestId>tx0000000000000000000'
2020-06-14T13:52:50.570 INFO:tasks.workunit.client.0.smithi026.stderr:         b'02-005ee62bb2-1090-default</RequestId><HostId>1090-default-default</'
2020-06-14T13:52:50.570 INFO:tasks.workunit.client.0.smithi026.stderr:         b'HostId></Error>',
2020-06-14T13:52:50.570 INFO:tasks.workunit.client.0.smithi026.stderr: 'headers': {'accept-ranges': 'bytes',
2020-06-14T13:52:50.570 INFO:tasks.workunit.client.0.smithi026.stderr:             'connection': 'Keep-Alive',
2020-06-14T13:52:50.570 INFO:tasks.workunit.client.0.smithi026.stderr:             'content-length': '219',
2020-06-14T13:52:50.571 INFO:tasks.workunit.client.0.smithi026.stderr:             'content-type': 'application/xml',
2020-06-14T13:52:50.571 INFO:tasks.workunit.client.0.smithi026.stderr:             'date': 'Sun, 14 Jun 2020 13:52:50 GMT',
2020-06-14T13:52:50.571 INFO:tasks.workunit.client.0.smithi026.stderr:             'x-amz-request-id': 'tx000000000000000000002-005ee62bb2-1090-default'},
2020-06-14T13:52:50.571 INFO:tasks.workunit.client.0.smithi026.stderr: 'reason': 'Not Found',
2020-06-14T13:52:50.571 INFO:tasks.workunit.client.0.smithi026.stderr: 'status': 404}
2020-06-14T13:52:50.571 INFO:tasks.workunit.client.0.smithi026.stderr:DEBUG: S3Error: 404 (Not Found)
2020-06-14T13:52:50.571 INFO:tasks.workunit.client.0.smithi026.stderr:DEBUG: HttpHeader: content-length: 219
2020-06-14T13:52:50.572 INFO:tasks.workunit.client.0.smithi026.stderr:DEBUG: HttpHeader: x-amz-request-id: tx000000000000000000002-005ee62bb2-1090-default
2020-06-14T13:52:50.572 INFO:tasks.workunit.client.0.smithi026.stderr:DEBUG: HttpHeader: accept-ranges: bytes
2020-06-14T13:52:50.572 INFO:tasks.workunit.client.0.smithi026.stderr:DEBUG: HttpHeader: content-type: application/xml
2020-06-14T13:52:50.572 INFO:tasks.workunit.client.0.smithi026.stderr:DEBUG: HttpHeader: date: Sun, 14 Jun 2020 13:52:50 GMT
2020-06-14T13:52:50.572 INFO:tasks.workunit.client.0.smithi026.stderr:DEBUG: HttpHeader: connection: Keep-Alive
2020-06-14T13:52:50.572 INFO:tasks.workunit.client.0.smithi026.stderr:DEBUG: ErrorXML: Code: 'NoSuchBucket'
2020-06-14T13:52:50.572 INFO:tasks.workunit.client.0.smithi026.stderr:DEBUG: ErrorXML: BucketName: 'smithi026'
2020-06-14T13:52:50.572 INFO:tasks.workunit.client.0.smithi026.stderr:DEBUG: ErrorXML: RequestId: 'tx000000000000000000002-005ee62bb2-1090-default'
2020-06-14T13:52:50.573 INFO:tasks.workunit.client.0.smithi026.stderr:DEBUG: ErrorXML: HostId: '1090-default-default'
2020-06-14T13:52:50.573 INFO:tasks.workunit.client.0.smithi026.stderr:ERROR: Bucket 'multipart-bkt' does not exist
2020-06-14T13:52:50.573 INFO:tasks.workunit.client.0.smithi026.stderr:ERROR: S3 error: 404 (NoSuchBucket)
2020-06-14T13:52:50.574 DEBUG:teuthology.orchestra.run:got remote process result: 12

/a/kchai-2020-06-14_12:49:00-rgw-octopus-distro-basic-smithi/5146269/teuthology.log

History

#1 Updated by Kefu Chai about 2 months ago

  • Subject changed from octopus: rgw/test_rgw_orphan_list.sh fails due to NoSuchBucket to rgw/test_rgw_orphan_list.sh fails due to NoSuchBucket

/a//kchai-2020-06-15_00:30:03-rgw-master-distro-basic-smithi/5146487

#2 Updated by Casey Bodley about 2 months ago

  • Assignee set to Eric Ivancich

#3 Updated by Casey Bodley about 2 months ago

  • Tags set to orphans

#4 Updated by Eric Ivancich about 2 months ago

I suspect this is related to https://tracker.ceph.com/issues/45571 , which is an issue with the sepia lab provisioning system.

Note that the hostname is smithi026 rather than smithi026.front.sepia.ceph.com.

It looks as though the hostname smithi026 is being mis-interpreted as the bucket name.

But I'll do some additional investigation.

#5 Updated by Eric Ivancich 25 days ago

  • Status changed from New to Duplicate

Also available in: Atom PDF