Project

General

Profile

Bug #45594

cephadm: weight of a replaced OSD is 0

Added by Kiefer Chang 7 months ago. Updated 4 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
cephadm/osd
Target version:
% Done:

0%

Source:
Tags:
Backport:
octopus
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

Not sure if this is intended.

After deleting an OSD with `--replace` flag and create new OSD on it, OSD's WEIGHT is 0.

─# bin/ceph osd tree
*** DEVELOPER MODE: setting PATH, PYTHONPATH and LD_LIBRARY_PATH ***
2020-05-19T07:38:24.802+0000 7f88013fb700 -1 WARNING: all dangerous and experimental features are enabled.
2020-05-19T07:38:24.822+0000 7f88013fb700 -1 WARNING: all dangerous and experimental features are enabled.
ID  CLASS  WEIGHT   TYPE NAME             STATUS  REWEIGHT  PRI-AFF
-1         0.32983  root default                                   
-3         0.29576      host ceph-master                           
 0    ssd  0.09859          osd.0             up   1.00000  1.00000
 1    ssd  0.09859          osd.1             up   1.00000  1.00000
 2    ssd  0.09859          osd.2             up   1.00000  1.00000
-7         0.03407      host osd0                                  
 3    hdd        0          osd.3             up   1.00000  1.00000        <----
 4    hdd  0.01949          osd.4             up   1.00000  1.00000
 5    hdd  0.01459          osd.5             up   1.00000  1.00000

History

#1 Updated by Sebastian Wagner 7 months ago

  • Assignee set to Joshua Schmid

#2 Updated by Joshua Schmid 6 months ago

  • Status changed from New to In Progress

This is certainly not intended.. I'll investigate

#3 Updated by Joshua Schmid 6 months ago

The initial weight is never restored after `draining` the OSDs.

We can save the initial weight/reweight and reset it after the osd is empty and has a `destroyed` flag assigned. This will prevent the OSD from receiving new PGs

#4 Updated by Sebastian Wagner 4 months ago

  • Category changed from cephadm to cephadm/osd

#5 Updated by Joshua Schmid 4 months ago

  • Status changed from In Progress to Fix Under Review
  • Pull request ID set to 36151

#6 Updated by Sebastian Wagner 4 months ago

  • Status changed from Fix Under Review to Resolved
  • Target version set to v15.2.5

Also available in: Atom PDF