Project

General

Profile

Bug #45067

mgr/dashboard: redirect to original URL after successful login

Added by Ernesto Puerta 10 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
dashboard/usability
Target version:
% Done:

0%

Source:
Tags:
Backport:
nautilus, octopus
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

Currently, when a user enters a URL (different from the the landing page), they first get redirected to the login page for authentication, and once succeeded, a user would expect to reach the page they originally intended.

Angular guard-based solution


Related issues

Copied to mgr - Backport #47155: octopus: mgr/dashboard: redirect to original URL after successful login Resolved
Copied to mgr - Backport #47156: nautilus: mgr/dashboard: redirect to original URL after successful login Resolved

History

#1 Updated by Avan Thakkar 6 months ago

  • Status changed from New to In Progress
  • Assignee set to Avan Thakkar

#2 Updated by Lenz Grimmer 5 months ago

  • Status changed from In Progress to Resolved
  • Target version set to v16.0.0

#3 Updated by Avan Thakkar 5 months ago

  • Status changed from Resolved to Pending Backport
  • Pull request ID set to 36582

#4 Updated by Avan Thakkar 5 months ago

  • Copied to Backport #47155: octopus: mgr/dashboard: redirect to original URL after successful login added

#5 Updated by Avan Thakkar 5 months ago

  • Copied to Backport #47156: nautilus: mgr/dashboard: redirect to original URL after successful login added

#6 Updated by Lenz Grimmer 3 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF